Swap fails repeatedly

I tried to swap from PRV to BTC, but it failed 5 times in a row. Are there any issues with swapping at the moment?


When it fails, those status is shown In transactions:

Request status: Rejected
Status: Fail

1 Like

Same for me. No luck swapping even a few bucks worth of PRV for BTC or USDT.


Either with Monero

1 Like

@Support @Jared Can you take a look, please? I see that sell orders for PRV to USDT aren’t executing either and are stacking up. My understanding is that these are used to contribute liquidity for swaps of the same token pair. Something seems akilter…


Any news here?

1 Like

Hello @GoldFella @3prime @henno,

Please try using Limit Orders when swaps are failing. You can do so via the Buy / Sell options via the top of the trade screen.

Limit orders have been failing for me too…

Thank you @Jared for replying. However, I also encountered that Limit orders never being filled.


I mean, a sell order at a price lower than the current price that would immediately match the buy order could not be filled. I am not sure how selling/buying works.

Buy and sell orders do not match each other. They get filled when there is a swap. Check this link to understand how the protocol works
Introducing the new pDEX (pDEX v3)

1 Like

So you need to make a limit order and hope that someone else tries to use swap which people are being told not to use because it doesn’t work. Hopefully swap starts working so your limit orders will be filled, which you are making because swap doesn’t work.


Deadlock :sweat_smile:


I submit limit sells and nothing happens… No error message, it takes the .1 prv, and it never shows in the order book. I have multiple successful orders in, and I’ve tried numerous times in the last week, but they keep “failing.”


I believe I found the answer to my problem here. I counted that I had 10 limit orders in the book (10 total, in different pairs, with buys & sells). I cancelled 1 of my open orders then placed a new order, which was properly entered into the order book.

Apparently there is a limit of 10 open orders??! I don’t know why this would be true, and there’s no error when you place the 11th order - it looks like it’s going through, it takes the .1 PRV fee, but the order never gets entered into the book. Why the limit of 10 open orders??

Thank you

i dont think it limit 10 orders per account. It just the wallet app only show up 10 orders for better view. Just to be sure, please make the 11th order, then ping @support with your pDEX ticket (found it in More/Setting/Tickets)

PS: i checked and swapping still work on my end. can you retry?

You are correct - must have been a coincidence… For some reason my new limit orders were failing, but now they appear to be working.

Any update here?

Yes, please see this post: