Firmware update now available for Node device

With today’s app release (3.9.4), Node device operators can perform a firmware update. It’s important because:

1/ It solves instances when [Fix it] appears incorrectly

Before the latest firmware upgrade, the app would sometimes show this message even when there weren’t any problems with the Internet connection/ power source. This happened because the Ubuntu OS of the Node went to sleep after an inactivity period.

After updating, this erroneous [fix it] message will no longer appear, and users need only pay attention to whether the Node is offline or not.

2/ Here’s how to update your Node firmware:

  • Power cycle the Node (unplug and plug in again)
  • Open the Incognito app. Tap on “Power” to get to the Node screen.

  • Wait until all your Nodes have loaded fully. If you are using an old firmware version, the app will perform an update automatically. It will take about 5 minutes. Simply wait and come back later.

  • You should now have the latest firmware version: 1.0.5. You can check for it in the Node detail screen.


Of course, to get the latest firmware upgrade, you’ll need to make sure your Node is online. If you’re using Ethernet, just connect the Node to your router and perform the steps above. If you need to change your Wi-Fi network, follow these instructions first.


With this update my node (v. 1.0.3) went Offline after the power cycle. In the app is still 1.0.3 and offline. Waited 10min. What should I do?
My node is in my family house so I can not do things except remotely power cycle. The node is also in pending phase so I need it up ASAP without messing things.
I need your confirmation before doing another power cycle.

Power cycled the node. Still offline. And I was in pending for rewards…
Can someone assist me? I think the last update is not working and messed up everything. I can not see the node anymore in my router. I will try to power cycle another time!
After another power cycle the node is updated and online.
In my case:

  • power-cycled the node
  • opened the updated app (the node was 1.0.3)
  • After 5 minutes the node went offline
  • waited more than 30m
  • power-cycled the node, but it still was offline. Waited 5m
  • power-cycled the node another time
  • Currently node is online with 1.0.4
  • Will monitor if everything is OK. But probably the problem is solved now

I don’t know, probably the user have to power-cycle another time after the update? Or it was just an anomaly? However problem seems solved.

Hi @Horus87, after the first power cycle, Node will start updating the firmware. During that time, it is normal if the Node is still shown as “Offline” in 5-10 minutes.

If it is still offline after 10 minutes trying, feel free to power cycle the Node. I believe the upgrade is failed after the first trial (Internet connection is not stable is also a reason), you may need to power cycle again so the app can retry the upgrade for your Node.

Happy to hear that. Let us know if you see any problems while the Node is using the 1.0.4 firmware.

1 Like

One of my nodes is showing the version 1.0.4 but will show online and offline at different times. Internet connection is stable. Is that an issue with the update?

@JG20 could I have your QR code to check?

1 Like

My node just updated to 1.04 and seems to be running hard (loud). Has been since I unplugged it and plugged it back in this evening. It was offline all day before I did a power cycle. Is that the update? It’s been going for almost 20 minutes.
Edit: still going strong… 1 hour later.
@Peter @andrey @Chucky @ anyone?

@FutureMiner is that a fan sound or something else?

It was the fan, and the node was getting quite warm. I unplugged it for about 10 minutes last night and plugged it back in and it seems to have settled down and is now back to being on standby for the next earning session.

1 Like