(Solved) pNode not connecting to network

Hi @Support, My pnode is offline and is not connecting to network. How can I fix it?

Are you able to locate the IP address on your router?

No, the device is offline as per router device list. I tried power cycling and the device is not coming back online.

In that case, you are forced to do a hard reboot. Please unplug the power cable. Wait 30 seconds. Plug it back in.

Do you see a blue light? There should be a :large_blue_circle: blue light on the side of the pNode with the fabric panel.

I tried the hard reboot but the device is not coming back online. I do see the blue light on the device.

Is your pNode connected via Ethernet or Wi-Fi?


Unplug and re-plug the ethernet cable. Make sure both the pNode and router have blinking/flashing lights on the ethernet port.

I see the lights flashing on the router but the light on the pNode is on but not blinking.

Try unplugging the ethernet cable. Unplug the power cable. Plug the ethernet cable into the pNode and ensure it clicks into the connector. After that plug the pNode in again and watch the lights on the side of the pNode.

If this does not fix the issue, let me know and we can try more advanced troubleshooting.

Yes, the lights flashed during the power cycle. But the device is not coming online.

In that case, you will need to use a credit card or something thin and pop the side (plastic side where HDMI connects) off and access the HDMI cable port. Once the side is removed connect the pNode to a TV or monitor and send a picture of what comes on the screen after booting.

Do you have image of this, what needs to be poped out?

There are 6 plastic clips (red circles) holding the plastic panel on. Slide a thin card or tool along the magenta lines to pop the side off.

This is what I see upon hard reboot.

Connect a USB keyboard and type

fsck -yf /dev/sda2

and then hit enter.

You will be asked various prompts. Just type y and then hit enter for each.

After it is finished type reboot and then hit enter. Wait for it to boot again and let me know what it does.

This issue is generally caused by power issues or pulling the plug on the pNode.

I see this one and the device is back online. What do I do now?

Run an SSD check with the following:

sudo apt install smartmontools
sudo smartctl -t long /dev/sda

Wait 12 minutes

sudo smartctl -l selftest /dev/sda

Do you suspect any SSD failure? I see that the pNode is syncing now.

Best to make sure there was no damage during a power failure.