(Solved) Incognito CLI failing to retrieve balance

Until now I’ve been able to retrieve the balance just fine, but just recently an error message appeared.

2024/01/30 02:00:36 ReadAll unexpected EOF
2024/01/30 02:00:36 [-3000] Error when retrieving balance: unexpected EOF

Is anyone experiencing the same problem?

i still able to retrieve balance with this command

./incli -c 1 -d 1 account balanceall -p $PKEY

You can use your own fullnode by edit
/Users/username/go/pkg/mod/github.com/incognitochain/[email protected]/incclient/constants.go
then rebuild incognito-cli

1 Like

I had that problem yesterday but it is working today

Yes, it works now.

1 Like

Having this problem again. I can check my balance but when I got to withdraw rewards:

2024/02/15 11:42:08 Init to https://beta-fullnode.incognito.org/fullnode, activeShards: 8
Withdrawing the reward for tokenID 0000000000000000000000000000000000000000000000000000000000000004, using tx version 2
2024/02/15 11:42:09 ReadAll unexpected EOF
2024/02/15 11:42:09 [-4002] Cannot create reward withdrawal transaction: unexpected EOF

Same problem as posted earlier which seemed to resolve itself after a period of time.

Also have CLI problems today out of nowhere when trying to stake a new node using same process as always

Hello @bjeung,

@brico84 just reported to me that their TX went through. Can you try again and update me if it goes through?

I have a service that uses the incognito cli and it failed for 7 hours. As you say, it’s back to normal now, but this should be investigated further to prevent this from happening again.

I understand, the dev team is looking into it.

You might want to consider running the CLI via your own fullnode:

1 Like

I can check my reward balance just fine, but withdrawing still fails with EOF

Hello! I am pretty new in crypto currency but i getting the things yet.
. So i have few transactions for which i suddenly forgot because i lost phone with 1st wallet and recovery phase but i have luckiness to find other way SOS haha, and restored them, and i revenue them all the time to stay at least SHIELDED beacuse i didn’t get that amounts and i don’t want to lose them… Can you help me please??:pray::pray:

2 Likes

Hey Jared, any progress from the dev team?

1 Like

It has been failing for almost 3 or 4 days now.

Yeah im taking a look at this

Issue fixed, i am able to get account balance. Can you guys retry?

Yes, it is working. Thank you

1 Like

I was just able to withdraw rewards which is the problem I was having.

1 Like

Having the EOF issue again this morning when trying to withdraw rewards