[Solved] App Showing 0 Balance

I shielded some ETH yesterday. I never received a notification that the transaction went through, but afterwards the app displays that I have no crypto holdings or anything in provide.

How can I fix this?

Hello @JonSnow,

Check your wallet balance (pie chart button at the bottom right) for the missing funds.

If you can not find them go into settings and click Clear Balance Cached.

Clearing my balance cache did not work. My pie chart (wallet) and my provisions are still showing a 0 balance. It also appears that my transaction history has disappeared.

Try clicking the wallet in the top right and clicking through them. There are various wallet keychains.

Give it a little bit to update the balance or swipe down to force refresh.

It appears I only have a single wallet (anon). Not sure what happened to the others, because I thought I used to have several.

I have tried refreshing balances several times without any luck.

I also notice that my Ethereum shield address has changed (generated address). This has always been the same address in the past, so I’m not sure why that would have changed.

The app seems very buggy all around, and it freezes up temporarily whenever I do basically anything (android).

I am starting to get a bit worried, as I have quite a bit of value stored on the platform and a sizeable ETH shield from several days ago has not shown up (old generated address, not the new one that I noticed today).

Please check two more things for me.

Under More > Settings check to make sure the Network says Mainnet. If it does not, change back to Mainnet.

The second thing is try to reimport your key phrase. Does it let you reimport or does the app say it’s already imported?

I am on mainnet. I have two keys, it appears only one of them is actually imported into the app and active as an account, but I cannot import either of the keys.

I get an error message saying, “Please try again with a valid key”.

Is it possible the syntax for the key is wrong? I just have spaces. Should it have commas or something?

I get the same error message for both keys, despite one already being active as an account.

I just attempted to restore my account on my wife’s iphone using my master key seed phrases, and that did not work either.

I attempted to import them using the QR code generated in my android app scanned by my wifes iphone. However, once the seed phrase is entered on the iphone app, and it appears to be correct, the blue import button is greyed out and cannot be pressed.

There is clearly something wrong with both the android and iphone app, and at this point I can only conclude these are bugs and not user error. What can I do to fix this? Am I the only person experiencing these issues somehow?

Hello again @JonSnow,

That is very odd you have encountered this issue. I have sent this to the devs and they will look into this further.

1 Like

Thank you.

Hi @JonSnow Could you give me the screenshot ETH history and your OTA key (More -> Keychain -> Select your keychain). Thanks for your patience.

@Jared @Sang Like I said previously. It appears all of my transaction data has been deleted.

I believe that my primary wallet may have somehow been removed, and the wallet that is active now has never been used. I used to have several options for wallets in the app, but now I only have one, the wallet labeled anon by default I believe.

Is there any issue with sharing my OTA key publically? Which keys should I never share? I am unfamiliar with the functions of the various keys. Do you have a link that describes them all? I couldn’t find anything with a quick google.

@sang @jared

I just solved my problem. Somehow my main wallet got deleted from the app. I have no idea how that happened, but that was the start of my issue.

When I tried to restore the deleted wallet I couldn’t do it because of operator error/poor UI.

I kept trying to import my master key seed phrase in the wrong section of the app keychain>actions>import a keychain. This requires a private key to import a chain, and not a seed phrase I believe.

I did not realize that the correct place to import my wallet was hidden up in the top right corner, clicking the wallet icon and then finding the option to import a master key with a seed phrase.

I believe I am all set and my balances appear correct as far as I can tell. Thanks for the help, and sorry for the runaround.

2 Likes