(Resolved) Swap doesn't work

Hello, the SWAP has not been working for me for 3 whole days. I click on it, first the system takes the crypto, and then it writes that the funds have been returned and nothing happens. I tried to place orders, they don’t work at all and just nothing works. When will you fix it? How long should I wait?

1 Like

Hello @JoWiry and welcome to Incognito! :raised_hands:

What pair(s) are you attempting to swap?

These pairs: PRV/USDT, PRV/DOT.

Please try placing limit orders via the Buy / Sell options at the top of the trade screen.

Hi @Jared. My swop feature also stopped working in the past week or so. Trying to swap PRV for BTC fails. Tried using the buy/sell feature but they do not go through (I hit cancel after waiting several days).

1 Like

I have had the same issue but I set a limit order to 0.13 cents and it went through. The first one went through in an hr the second took maybe 4 hrs.

Same happended for me ETH/XRP. I dont get my ETH back even after transaction failed, what is this about…?

Hello @Xehiss,

I’ve just replied to your support ticket.

It seems to be working fine now.

1 Like

It’s fixed!

1 Like