[Solved] vNode is shown as offline with 20201223_1 tag


I have the same problem. I have two vnodes running and both were running fine (green) and one already minted blocks and created rewards. On the latest epoch transition both nodes turned “offline” (grey) without any obvious reason. docker stats showed both running fine + the eth chain. However I did restart the nodes without any effect. Then I removed the nodes in my app and when trying to re-add them I end up with the “import” button as the guy above.

Querying “gotsignal” shows both port are reacting just fine, so firewall obviously isn’t an issue. Any ideas?

I also tried removing the keychain and adding it again using the private key, same result. I am really lost here…

Only thing I can see is there was a new docker image obviously today:

Status: Image is up to date for incognitochain/incognito-mainnet:20201223_1

Maybe something has changed with the latest docker image?!



Can confirm it works with the release before! Please check the lates docker image guys! Thanks for the heart attack :smiley:


Thanks @scooter, we will have a check.


Thanks! Is the latest release mandatory to be elected, or does the old one work as well? And does docker automatically update itself?

Cheers and merry Christmas everybody!


Hi @scooter, they should be updated automatically. So on the node side, all the instances are running fine and data is up-to-date. Your app is still showing “Import”? Did you nano the run.sh file to check the validator key is tied yet?

Hi Peter,

I manually edited the run.sh to use the 20201113 instead of pulling the latest one. With the latest docker image I always saw “import” only, with the previous one the node showed up. Validator key is identical in both run.sh scripts as I only duplicated and edited out the “pull latest docker image” part. really strange…

Was just wondering if my nodes are eligible to be chosen also with the previous docker image! In the app both look fine (green/online).

image image

At this moment, your Nodes are still eligible to be chosen with the previous docker image.
Let’s wait for other reports from the community. If the problem is the latest docker as you believed, you will not the only one.

Yes, very curious if anybody else is having this issue. Was trying around with it again today but can’t get it working with the docker image from yesterday. Very strange indeed… Will update here in case I find a solution!


I have the same issue. Node earned during the last epoch and then just went offline. I’ve double checked that my ports are accessible via the Internet, restarted my node, updated everything, etc. etc. Interestingly, my node is still processing something, so it’s like the node is connected but the app can’t see it. Definitely a +1 from me.


Thanks @Joseph. Our devs are alerted and they are working on it. Getting Node status may have a problem at this moment. But rest assured that your earning/ chance to get selected is not affected.

I will keep you guy posted.
cc: @fitz_fiat


I have the same exact issue here with 3 of my Vnodes.


Since you are not a/the Incognito “founder”, your account name is misleading and can confuse users. Can you change it to something more suitable?

1 Like

Thanks for confirming this issue! I am still running the previous docker image and my nodes are shown online in the app. However they haven‘t been chosen yet so I can‘t confirm they are working properly.

What is the suggested way to go atm? Run the old docker image or the new one and ignore that the nodes are not shown properly in the app?

Hi all, getpublickeymining RPC doesn’t give BLS key as a result atm, so the app can’t show the correct status of your Node.

We will release a new tag to fix this issue today/ tomorrow. There is nothing to do on your end. I will keep you guy posted when it is up.


Great, thanks! So we are still supposed to run the new image or can we stick to tje old one until the new image is available?

Hi all, a new tag is released: 20201225_1


Your Node should get new tags automatically whenever there is a new version available.

However, it never hurts to be doubly sure! Let’s ssh to your server and enter this command to check: sudo docker ps

In the unlikely case that it has not been automatically updated, simply restart the script using this command: sudo bash run.sh

What if I operate a physical Node?

Nothing is required on your end. It’s plug and play!

What if I am not using Docker?

You can get the new tag here: https://hub.docker.com/layers/incognitochain/incognito-mainnet/20201225_1/images/sha256-c889115a6673c425fd35006045d7f0dfee53ff23d4f779631094269f184fe0c8

Let me know if you have any questions or encounter any issues. Thanks!


Hi Peter,

thanks for pushing the update. It worked for me an the vNode is running 20201225_1 now and nodes show online in the app again!

Screenshot 2020-12-25 at 11.34.55

1 Like

Read the entire string…thank you scooter for alerting the community as to the issue…and especially thanks to Peter for getting on it and getting with the dev team and finding the causing issue and a fix to the problem…Peter you da man…hehe…lots of love for Jamie who is always there as well… :sunglasses:


14 posts were split to a new topic: Import message randomly appears for vNode owner