[SOLVED] Missing BAT coins after Shielding and Trade Preview

I shielded BAT and received notification that my Account 0 balance had been updated. An hour later I looked in my incognito wallet on Account 0 and was looking at different ways to trade the BAT with either pKyber or just to PRV

I previewed the pKyber transaction, but realized I didn’t have enough PRV in current wallet to cover trading fee, so switched back to just trade directly for PRV.

But after returning back to main wallet asset page to check my PRV balance, my BAT is gone. Not sure what happened to it as I didn’t have enough PRV to perform the pKyber swap to USDC, and I never tried to execute trade, only previewed.

Here is etherscan to show where BAT entered into my wallet, but at this point there is nothing to screenshot because at BAT accounts in my wallet now show 0 and there are no pending transactions showing on any of my BAT or PRV wallets either.


When I switch between wallet accounts, I do see an error bubble that pops up and states:

Cant switch to "Account 0", please try again
Error: Error: Can not derive serial number

I am not sure if this error is connected to the disappearing BAT, but thought I would add it to the report

Hey @doc I got the same error message as yourself and believe they are doing updates on the back-end of things.

1 Like

Sounds very similar, maybe this is associated with the new update to Pool v2 as you were suggesting and it will be fixed soon.

1 Like

Yeah I hope they have it up soon. I had my mind made up to setup another node tonight but rather hesitant now.

Hope they have it fixed soon. If not might be an exit scam. Only kidding :laughing: (nervous laugh)

I have 3 nodes running, and have been very happy with them… I think we will be fine, but I am also less nervous because my BAT was only worth $4… I can imagine someone with way more in those wallets being way more nervous. Vanishing crypto is never good.

Yeah I’m a little more exposed than you. With 5 nodes, 1750 PRV, 7.22 ETH, and something like 0.24 BTC.

paces back and forth slowly

1 Like

Spoke with the devs on Telegram. This is now fixed in another update and was a bug.


Thanks @Jared for your so quick update! :+1:

Hey @doc, how is the situation from you? Please update your app to the new version and let me know if it works well for you now.


That fixed it for me!

1 Like