[Solved] Incognito-cli's send method not working

When I run it exactly as I normaly do, I get this error:

host: https://beta-fullnode.incognito.org/fullnode, version: 2
Send [[X]] of token [[PRV id]] from [[my private key]] to [[payment address]] with version 2
2022/07/02 16:25:36 DoReq {"Jsonrpc":"1.0","Method":"listoutputcoinsfromcache","Params":[0,999999,[{"OTASecretKey":"[[omitted]]","PaymentAddress":"[[omitted]]","ReadonlyKey":"","StartHeight":0}],"[[PRV id]]"],"Id":1} error: Post "https://beta-fullnode.incognito.org/fullnode": EOF
2022/07/02 16:25:36 Post "https://beta-fullnode.incognito.org/fullnode": EOF

This is what I ran:
incognito-cli --host https://beta-fullnode.incognito.org/fullnode send --tokenID [[PRV id]] --amount [[X]] --address [[receiver payment address]] --privateKey [[my private key]].

1 Like

Please upgrade to the newest version.

I just tried using the most recent release and the error is still there. Previously I compiled it by my own with the latest main commit.

Sometimes it outputs a transaction hash, but I never receive or send anything. The explorer throws a server error when I try to search for the transaction:


Oh, no, wait, I was indeed using an old version. Sorry for bothering.

No problem. Glad it’s resolved. :raised_hands:

Hey @J053, if you were using the CLI tool, you might want to have a look at the useful tips/info, thanks.