(Solved) Confirmation errors with Provide feature


On the Android version, I keep getting Confirmation errors whenever I try to add funds to Provide. The first time I try, I get this error message:


If I retry it, I get this message:


I don’t know if it makes a difference, but I’m running this in the Bluestacks Android emulator on a Windows 10 machine. The old version of Incognito worked perfectly with Bluestacks, which makes me suspect that Bluestacks isn’t the problem.

Also, I attempted to withdraw my PRV from Provide, and got the same errors.

Many thanks in advance!


Hi, some services may not work on the emulator. So we strongly recommend you to use a real phone device to use our app, especially the “Provide” function.
Thank you!

Okay, I installed it on my phone, and everything works there as it should. But, in case it helps you to know, it appears that the Provide function is the only thing that doesn’t work with Bluestacks.

Many thanks!

hi, we have enabled Captcha feature on Provide screen, so maybe it doesn’t work on Bluestacks. Thanks.

Okay, that probably explains why the Provide feature on the old version of Incognito worked on Bluestacks. Oh, well. I guess I’ll have to look forward to us getting a desktop app. :wink: