[Solved] Cannot import node with masterless keychain

Hey Incoggers, I am having trouble getting app to add an existing Node Virtual to my list. The node was moved IPs, but when I tried to import the keychain, I removed it as usual, then input new node location, and tried to import. When it said no masterkey was associated with the keychain and gave me the option to import the masterkey or just the keychain, I picked the latter, but then just the keychain imported to the masterless keychain list but there is just a hyphen listed where the key name goes on the node list and it doesn’t associate with anything. Any ideas?

Hmmm… maybe @support has some idea what to try. This sounds very upsetting.

1 Like

Yes, even more maddening is that there has been zero response to such a seemingly straightforward issue. This does not help keep confidence in the security of funds.

I’m not sure what all you have tried so some of the following may appear redundant but let’s try everything.

Have you stopped the docker container on the old server?

Does the app show the vNode as being online or offline? (Color indicator next to the node name)

Connect into your new server that is hosting the vNode.

Run ‘docker ps’ and make sure your docker container is running for this node. Write down the port number for this specific container.

Next run docker stats and make sure this container shows on this list and has data in and out.

Go to a port checking website (I like to use www.yougetsignal.com) and put in your server IP address and specific port number. Make sure you have an open port. If the port is closed then the new server is blocking it (therefore preventing Incognito from finding it).

Please reply back to each step. I’m sure we can figure this out with some trial and error.

Rest assured your funds are 100% safe and have not gone anywhere.


Hi guys, this just started working without explanation. I removed the node and readded to app for what had to be the 20th time and it worked. Will proceed with unstaking. Thanks.

Awesome. I’m glad it ended up working for you. Sometimes things just take a little bit to transfer over.

I’m gonna go ahead and mark this as solved.