pNode wifi setup issue

I keep receiving this sequence of error messages during node setup.

“Could not add or update network configuration with SSID Node-XXXXXXX.”

“Could not setup wifi and connect to node: Could not add or update network configuration with SSID Node-XXXXXX”

“Could not setup Node Wi-Fi”

Tried power cycling node and phone several times. App is updated. Android phone is new and updated. Cellular is off. Node visible in wifi networks. Location access is on. Tried both of my home wifi networks. Followed all instructions and went through all of the “Need Help” sections.

What do I do next?

@Support

Are you using Android 10?

1 Like

Yes android 10

I ended up hooking mine up to the ethernet and then was able to move it over to wifi.

Are there instructions anywhere on how to do that?

I made a topic on the same issue. I have 6 pNodes here ready but I can’t connect them to WiFi.

Google has changed some policy for wifi control on Android 10. So we’re having issue with setup node/update wifi on Android 10. Please contact @Peter for support.

1 Like

Hi @sjo114 @SynthiaNominae, we are thinking about a temporary way to help you set up the Node. I will keep you guy posted.

2 Likes

Ethernet? I can do that.

1 Like

Thank you! I can’t use the Ethernet option, the area where I keep my pNodes is too far from my router, and I can’t run 12+ Ethernet cables to my little home router…

Buy a 16 port switch, place it near your nodes then run one Ethernet cable between your router and the switch.

1 Like

Hi @sjo114 and @SynthiaNominae, the Node must be activated using the Wi-Fi connection to ensure the firebase token is activated.
Get back to this case, I wrote a guide here: [Android OS] "Could not setup Wi-Fi and connect to Node"

Hope that works.

2 Likes

That was nerve-wracking, but it worked. THANK YOU!!!

3 Likes

Will try this process soon and post update on results. Thanks.

@Peter This process worked. Thank you for the instructions.

A general tip to add to node setup: having the phone too close to the Node can cause the setup to fail. I guess due to wifi interference.

2 Likes

This one also worked for me at last. Thanks!

4 Likes

Hello, I just received my pnode so I want to configure it. I deactivate cellular data, I connect to my modem (I have two modems and tested the operation on two different modems, 2 different access providers) I scan the qr code, enter the wifi code, but when it is switch on the node-xxxx network, the application crashes and stops (when I go to the wifi parameter I am well connected to the node) I try x times to restart the 2 modems as well as the node (and forget the node network in wifi setting) and restart the phone too

What version is your wallet app? 3.11.0?

yes i have a 3.11.0

Hi @dmonter,

Could I know your device model and OS version?