Incognito chain’s code upgrade (tag: 20220214_1)

Hi Incognito validators,

We’ve just released a protocol code update for liquidity mining for selected Incognito exchange’s pools in PRV from DAO. The latest code is published in 2 forms:

If you run pNodes or set up your vNodes by following our instructions , they should pull the latest docker image automatically. In case you encounter any issues with the code update, feel free to contact @support for assistance.



Since this update my docker constantly crashes and reboots?! Any ideas?

When logging in to the node by ssh I get the message below:

I killed the docker image by "docker rm " and now it’s gone :smiley: After a reboot it doesn’t come back up anymore!

@Support Can you help? It was my turn to validate blocks in 3 epochs from now, and I am stuck…


I solved it. It was simply the gateway missing from the network interface config. Why this happened exactly when the new docker image was released doesn’t really make sense. Or does docker mess with the ifconfig? However, I fixed it on my end…


I am very impressed with Incognito as I didn’t have to do a thing and my vNodes were updated automatically.

@Jared , next time you talk to the core devs, can you please thank them for writing in to the code a really pain free upgrade process. Very much appreciated.


Seems like the gateway gets lost after the reboot. After reboot and a login through ssh I still get this message:

I added a permanent route and static IP by modifying /etc/network/interfaces

Screenshot 2022-02-16 at 17.35.41

Now when I log in to the shell it looks better:

The node is syncing now, but it still has problems resolving dns names for some reason…?! I can’t ping dns names:

Screenshot 2022-02-16 at 17.37.02

But pinging an IP works just fine:

Screenshot 2022-02-16 at 17.37.10

Thanks for any help! :wink:

Best scooter

My VPS provider messed up my VPS’s performance. Today, a little bit better. However, my nodes’ contribution to the vote has decreased to ~70%. Is there any other one facing decrease in the contribution after this update? Since VPS provider’s works and this update coincided, I’m facing some difficulty in analyzing the root cause. Thanks.

I haven’t noticed any issues on any of the nodes I run.


No issues on my side using contabo.


One of my Nodes just finished committee with the new Docker tag. 98%, 100% and 99% for the 3 epochs respectively.


Upon my insistent request, they’ve changed the host system of my VPS. Now, it runs blazingly fast. My vote count is 100% as before.

1 Like

Was the provider Contabo?

Yes .

What was causing the slow performance on your last host system? Host congestion, RAM usage, CPU, etc?

To my rough examination, CPU, network speed, and disk access speed were the main bottlenecks.

1 Like