Incognito app new version

Hi community,

Our new updated version of Incognito app is finally live! The release is mostly about performance improvement. A few key measurements to show how better the new version is as compared to the old version. Please note that these were measured for an account having ~10,000 output coins (both spent and unspent) on an iPhone 6 phone.

Old version New version
Import account 270s 30s
Reload account balances 60s 10s
Create trade transaction 80s 20s

(*) smaller is better

In addition, it also allows users to create multiple transactions continually instead of having to wait for a previous transaction to be finished as long as the account has sufficient available output coins.

We believe that the improvement will bring a better experience to users, please give it a try and let us know by reaching out to @Support in case you encounter any issue.

Thank you for your support!


Thank you developers!


Good work!

1 Like

@duc Maybe it’s just me, but the Withdraw All button only initiated withdraws on the pnodes…had to manually withdraw each vnode. Update issue?

Update: None of the vnodes are withdrawing. I click the button and nothing happens. Anyone else having this issue?

this is awesome @duc and team! been looking forward to this update.


@Support I can also confirm vNodes are no longer withdrawing with newest update.

1 Like

Thanks for the report @JG20, @Jared.
Hey @khanhj and @anho, can you please look into this? Thanks.

1 Like

@Support - I can also confirm that the vnodes withdrawal is not working with the new version.

@sid, @Jared,
Can you let us know your phone model, os version
Kill/stop the app running in background and make sure incognito-wallet version 4.3.3

I cant reproduce this issue on my devices (Nokia 8.1 and iPhone 12 Pro Max)

Having the same issue on iPhone SE 14.4.1, app version 4.3.3. Withdrawing on vNode page didn’t work, only when going to the main nodes screen and using the withdraw all button.

@khanhj - I’m using an Android (Samsung S20 Ultra). I have v4.3.3 of the Incognito App. For me, withdrawing from each vNode works, but the withdraw all button on the power screen doesn’t work. I will try killing incognito app, cleaning app cache and initiate the withdrawal again in a while. I’ll report back what I find.

1 Like

I have an iPhone 11 running 4.3.3 and the vnode withdrawal doesn’t work. When click the button, it gets grayed out, but when I leave that vnode screen and go right back in it’s blue again.

@khanhj - I tried killing the Incognito app (in the background), and removing everything else. Still doesn’t work. I tested this on Android (Samsumg S20 Ultra) and iPhone 8, 10. The issue persists across all phones and platforms. For clarification, the withdraw button appears fine on the Provide main screen and inside each v/pnode. Tapping on any of these buttons appears to initiate a withdrawal (like how you’ve shown in your video). However, the actual withdrawal doesn’t happen at all. In a few minutes, you see nothing happen and the PRV doesn’t move. The withdraw button becomes blue again and the cycle repeats.

Not being able to withdraw PRV rewards in a big deal (in my opinion). Please fix this issue ASAP!

Hi everyone. I checked and confirm this is bug, we will fix as soon as and update later, thanks.


Hey @Support @anho . Dunno if this helps or not. But I have been able to successfully withdraw my rewards from my nodes. I have to load the specific account that is associated with the node under “Assets” first. Then, if I go to “power” to select the node with my rewards and choose withdraw, it functions as normal. All other nodes with rewards do not withdraw unless I go through them one by one.


Genius! That worked for me as well. Thanks for figuring that out.

Hey guys, we’re working on the fix and this is a very good clue for us to investigate the problem. The ETA for it is today or tomorrow, FYI, thanks.


Hi everyone, the fix for rewards withdrawal issue was out. Please update the app and try again. Thanks for your patience!