Mesquka - Ecosystem Tools (Price Charts Addition)

No, it doesn’t change.

1 Like

I double checked, seems like the status is actually queried from the node itself. I might add in a check to see if the node block height is less than say 1000 blocks from the current block height and override the status to say ‘syncing’.

Hey @mesquka, thank you for building this. This is just to confirm that the rest of the fund has been released to you last week. I’m going to move this under Archive section.
We’d love to see more coming proposals and more contribution from you.

1 Like


I am sure you are already aware of this, but just wanted to place it here for others that might be getting 'stale" data on the Incognito Tool.

It appears the cors-anywhere app you are hosting on heroku is hitting a usage limit, and causing a 429 failure when querying node status. I imagine the issue is coming from the success of your tool to help the community and its adoption, which may require additional support by community to cover operational cost.

Either way, I really appreciate the tool and hope a solution can be found to help with the cost and fixing the limit rating on the app server.

1 Like

Hi @doc,

if it can help, I deployed Mesquka’s tool few weeks ago on my server:


Thanks for letting me know, I’m redeploying it with a new cors endpoint that will fix this issue. Good problem to have too much usage :laughing:

1 Like


1 Like

@andrey; should this be a funded project?

1 Like

Mate @davoice321,

  • why do you think that your time is more valuable than time of other people?
  • why you can’t find 5 min of your time to read what is written above and straight forward tag me with the question if this project can be funded?

If you find 5 min and read the proposal and comments below you will surprisingly find out that this proposal was funded on March 3

And fully completed on April 13

1 Like


I generally read the forums pretty closely.

I didn’t see that information, obviously.

No need to get salty and call me out for wasting your time.

You just had to say, it’s above.

Took you longer to call me out for asking your time than to respond in a more positive fashion.

Thanks for the information… mate

1 Like


I have been using your tool since I setup my first two vNodes and it has worked wonderfully, thank you so much for getting it going!

I have not got my first pNode set up and trying to connect your tool to query it for the same sort of status. I am able to do curls from console into pNode and it properly returns status informaiton, but when I connect up to Incognito Tool, I am unable to get results. I have tried it two different ways, both have failed.

One way was to use local IP address from site, and select “direct connect” option. When I do that, I get the following error in console:

I have also added a sub domain that points directly to my local IP for the pNode, and that also failed.

Any guidance here wold be appreciated on how to get this connected to pNode.

@doc – When using the Direct Connect method, you’ll need to enable Insecure Content to allow mixed HTTP and HTTPS connections.

For a Chromium based browser (Chrome, Brave, Opera, Edge, Chromium, et al):

  • Navigate to the
  • Click on the icon just to the left of the URL.
  • Click Site Settings.
  • Scroll to the bottom of the page.
  • Change Insecure content from “Block (default)” to “Allow”.
  • Close the Site Settings page and refresh

BTW a DNS hostname will work just fine, so long as it resolves correctly where you are using it.

1 Like

Thanks @Mike_Wagner

I updated the security settings and got a bit futher, but it is still throwing an error and not updating properly.

When I look at the Dev tools, I can see a proper response is being obtained from my pNode in the REST call, but there is in an uncaught exception happing on a promise that is preventing the tool from properly displaying the result.

here is screen shot of response

The call stack shows to be failing on call starting in call

API.refreshNodes() //Line 180 index.js

Specifically index.js line 171:

const nodeStatus = await API.getNodeStatus(node);
1 Like

Major faux pas on my part. I thought this was mesquka’s original tool. I completely overlooked that you were using inccry’s version of the tool. My apologies.

I just tried inccry’s tool and cannot get it to load my pNodes either. mesquka’s tool is still working for me.

1 Like

That is actually my bad, I was trying it on multiple browsers and both sites… I actually get the same error on both sites, I just happened to take screenshots from inccrys on accident.

1 Like

Heh. Well … that’s … strange.

As you noted, you are getting a response: your node is syncing the blockchain (ShardID -2), and is currently around ~93,000 out of ~450,000 blocks.

It’s odd that both tools fail to display the info. I’ve tried each of my pNodes with the DHCP reserved IP first, then with a local FQDN from my local DNS server. I am able to view details with mesquka’s tool. inccry’s tool does not currently work with either.

1 Like

Maybe @inccry or @mesquka will have a suggestion for either of the deployed versions.

1 Like

Unfortunately at the moment the tool derps and has some unexpected behaviour if the node it’s talking to isn’t synced fully - for some reason vNodes and pNodes fail in different ways.

I’m waiting on the ‘analytic-api’ from the team to be production ready before releasing an update to the tool as that will streamline a lot of the things it does.


Ahh, so this should go away once the pNode has synced the chain?


1 Like