(Answered) Trades Failing

I have been trying to trade (swap) DAI for BTC, ETH, and LTC for a couple hours now. Just small trades 1 or 2 DAI worth. Every time they’re getting rejected. I upped the slippage to 2%, still fail…

Finally getting some trades through, but don’t know why so many are failing…

Could you please give us a transaction id of the failed trade? then we will look into it to see why it’s failed.

These 7 all from just now. I had one successful DAI-BTC trade, then these all failed after that.



If possible, could you add a reason field (insufficient fee, unsatisfaction of minimum requested amount, invalid path etc.) for the rejection status? I think this will be better for both devs and users. @duc

1 Like

Getting Database or Disk is Full errors now… :frowning:

When doing what on the app?

Please provide a screenshot.

Attempting a trade (swap) - DAI for USDT. It gets to 90% then a red box flashes with text, “Oops! Something went wrong. database or disk is full (code 13 SQLITE_FULL).” I will try to get a screenshot, but it only flashes on the screen briefly.

Please try clicking the following under settings:

Clear Balance Cached

and see if that fixes the issue. If not, also click:

Clear History

Thank you Jared - this solved the database/disk full error…

1 Like

Hey @yoo, we’ve checked some of the failed trades above, they were failed because the receiving amount (after executing a trade) was smaller than the minimum acceptable amount put into the trade request.

There might be a few reasons caused that. You placed a few trades in a short time window then all of them used the same rate, for example, trade 1: DAI -> BTC and trade 2: DAI -> ETH, they went with trade path respectively: DAI -> USDT -> PRV -> BTC and DAI -> USDT -> PRV -> ETH. Both trades used the same estimated rates (due to having been placed in a short time window) for overlapped parts. That caused the latter to get a worse rate and its receiving amount was, unfortunately, smaller than the minimum acceptable amount.

Also, a trade with a long trade path usually has a higher failure ratio than shorter ones since the more pools involve a trade, the more chance for rates of those pools to change by other trades

Hope this answers your question. Thanks.

1 Like

Thank you @duc , as always! What you are saying sounds logical - however, I don’t understand why this is worse since the update. Yes, there was a very short period of time between trades, but my behavior is the same - trade dai (stablecoin) in small amounts for several large coins (btc, eth, ltc).

In fact, prior to the update, it was rare that my trades failed, and I always used 0.2% slippage. Because I’ve had so many failures since the update, most of my trades are 1-2% slippage - and most still fail now.

Regarding the trade paths, shouldn’t all of those coins in the paths have high liquidity pools, and thus very small changes in rates in short periods of time? Especially given that my trades involved small dollar amounts…

In those paths you’ve shown, I can see that DAI is creating an extra step over USDT. My problem with using USDT instead of DAI, is “The Tether Controversy,” and I prefer DAI. But, again I assume all these coins involved have some of the highest liquidity pools in the pdex and I never had trouble prior to the update. Also, shouldn’t there be a direct DAI-PRV path?

Though the entire process of submitting a trade is longer and more convoluted now with the new app. With the old app, I’d select the top coin (ex. DAI), select the second coin I want to “buy” (ex. BTC), tap advanced, change slippage to .2% and confirm. the whole page never reset or redrew, when I changed the coins it was fast, changing the slippage was fast, no re-drawing anything or new lookups. Now the app takes much longer to select the coins, it “refreshes / redraws the screen” at every step, it changes the amount of the coin I want to buy with (presumably because of the trading fee, though the amounts don’t match up but regardless it does some lookup and re-draws again). The entire process is way slower and very frustrating, because at many points I don’t know if it did not recognize my tap or if it’s working. Also it doesn’t show how much of the second coin I’ll get until I tap in the spot where that number should be shown (the number used to populate instantly in the old app).

Hopefully some of this is because of the major changes with the app/pdex and that they are being worked on/fixed/improved. I can understand that - however if this is the new way things will be, it feels like a few steps backwards…

Apologies for the long ramble - and thank you again!