vNode home brew

Not sure if my pNode is working or not. has anyone successfully set up a home node? How can I tell if mine is actually working? any help is much appreciated.22%20PM

1 Like

That picture looks like vNode interface not an app driven pNode interface.

So I am using SSH to remote into my pNode. Maybe thats why it looks like that. How should it look?

Is there a tutorial or a guide for setting up a pNode like we have for vNodes How to host a Virtual Node? If not can someone create one?

Im currently running Ubuntu Server latest on Mac Mini.

Is pNode what you are actually trying to run?
Running the Incognito software on a home computer would still make it a vNode.

Yes. Is there another route I should take to run the software?

A pNode is a standalone device with its sole function being to run as a plug and play node on the Incognito chain.

Your Mac is a multipurpose device running the Incognito software, that makes it a vNode.

So my question is, are you setting up a vNode, and named it wrongly?

An alternative pNode would be, running the software on a Raspberry pi for example.

1 Like

Is it possible to run my own node? I don’t mind using my Mac as just a node if it’s possible.

Is there another way of setting it up that hasn’t been posted yet?


In theory, it is possible to run a vNode on any computer that runs Ubuntu. A vNode is just a computer program. You may have to forward some ports to make your vNode accessible by the Incognito network.

Hosting a vNode on a home computer is mostly done by people who are tech-savvy enough to solve the issues that may occur.

Did you follow the guide?

Yes, but there are no instructions on forwarding the ports or at least pointing to a section on how to. Im currently running on a dynamic ip…

set everything back up and I get the first issue over and over where both the ETH and incognito main net keep restarting… im running ubuntu server on a Mac over dynamic all ports open… any help is much appreciated.41%20PM

this is what I get when I run docker logs on incognito container:
(( sudo docker logs --tail 50 --follow --timestamps Container_ID ))

2020-02-21T02:43:57.178940669Z Handling 0 logs

2020-02-21T02:44:59.568899958Z reading config file /tmp/logrotate

2020-02-21T02:44:59.569130554Z error: /tmp/logrotate:3 unknown option ‘secondly’ – ignoring line

2020-02-21T02:44:59.569149033Z error: /tmp/logrotate:8 unknown unit 'm’

2020-02-21T02:44:59.569162193Z error: found error in /data/*.txt , skipping

2020-02-21T02:44:59.569177993Z removing last 1 log configs

2020-02-21T02:44:59.569225472Z Reading state from file: /var/lib/logrotate.status

2020-02-21T02:44:59.569239792Z Allocating hash table for state file, size 64 entries

this is what I get when I run docker logs on ETH container:

2020-02-21T02:43:36.466262808Z 2020-02-21 02:43:36 UTC Inserting hardcoded block #8798209 in chain

2020-02-21T02:43:36.512588810Z 2020-02-21 02:43:36 UTC Debug API is not available in light client mode.

2020-02-21T02:43:36.513092841Z 2020-02-21 02:43:36 UTC Debug API is not available in light client mode.

2020-02-21T02:43:36.516587738Z 2020-02-21 02:43:36 UTC Debug API is not available in light client mode.

2020-02-21T02:43:36.518310987Z 2020-02-21 02:43:36 UTC Removed existing file ‘/home/parity/.local/share/io.parity.ethereum//jsonrpc.ipc’.

2020-02-21T02:44:39.580176394Z 2020-02-21 02:44:39 UTC Starting Parity-Ethereum/v2.5.13-stable-253ff3f-20191231/x86_64-linux-gnu/rustc1.40.0

2020-02-21T02:44:39.580234193Z 2020-02-21 02:44:39 UTC Keys path /home/parity/.local/share/io.parity.ethereum//keys/ethereum

2020-02-21T02:44:39.580355190Z 2020-02-21 02:44:39 UTC DB path /home/parity/.local/share/io.parity.ethereum//chains_light/ethereum/db/906a34e69aec8c0d

2020-02-21T02:44:39.580371550Z 2020-02-21 02:44:39 UTC Running in experimental Light Client mode.

Maybe @Peter or @khanhj can help you out.

1 Like

Hi Z3Y,

Let’s ignore those logs and remove your data first:
rm -rfv data

ps -ef | grep

kill -9

docker stop $(docker ps -aq)

docker system prune -a

Then, we start to set up again. Let me know how it works this time.

1 Like

When I set back up should I be in root? or can I be in one of the SSH users that have root access?

the ETH container is still restarting…

Hey @Z3Y,

We suggest user has root access or member of sudoer, so that you can execute docker command and write log, blockchain data to your storage.

Can you show us your file?
please ping me on telegram id @khanhj

1 Like

My issue seems to have been stemming from the ETH Parity. All necessary ports where opened but I would constantly have eth_container restarting.

sudo docker stop "eth_container_id"
sudo docker rm "eth_container_id"
sudo rm -rf eth-mainnet-data/
sudo docker run --restart=always --net inc_net -d --name eth_mainnet -p 8545:8545 -p 30303:30303 -v $PWD/${eth_data_dir_geth}:/geth -it ethereum/client-go --syncmode light --datadir /geth --rpcaddr --rpcport 8545 --rpc --rpccorsdomain "*"

And no more restarts. This is the short version of my fix after a few sleepless nights and with a big shout out to @khanhj for the helpful guide on and patience guiding me!


Thanks @Z3Y & @khanhj for your sharing.