Unable to add a remote validator via domain name

Some background:

  1. I have a personal VM host machine that is running the validator in a hyper-v VM.
  2. I have a personal domain and have a subdomain, ip.domain.com, pointed to my internal network via dynamic dns.
  3. I have port forwarded 9334 to the internal validator ip address.
  4. canyouseeme.org verifies the port is forwarded properly.

When I try to add ip.domain.com:9334 as a vNode it gives the error: “This address is not a valid domain or ip address. Please try another.”

What gives? The domain is certainly valid. I could use the internal ip address, but I want to be able to access the status of my validator when I am outside of my home.

Are you sure the node runs properly on the machine? Could you share what you see in (sudo) docker stats and (sudo) docker ps?

The node is running properly. I can add the node to the app via the internal ip address and it adds it just fine. Only when I try to add via external domain does it fail.

For posterity:

sudo docker stats
CONTAINER ID   NAME          CPU %     MEM USAGE / LIMIT     MEM %     NET I/O                                                                                                            BLOCK I/O       PIDS
597e2e584ed8   inc_mainnet   15.10%    280.1MiB / 3.787GiB   7.22%     1.01GB /                                                                                                   11MB    877MB / 170GB   20
b35f535842ea   eth_mainnet   0.25%     141MiB / 3.787GiB     3.64%     1.21GB /                                                                                                   103MB   65.5kB / 9GB    44

sudo docker ps
CONTAINER ID   IMAGE                                         COMMAND                  CREATED       STATUS       PORTS                                                                                                                               NAMES
597e2e584ed8   incognitochain/incognito-mainnet:20210106_1   "/bin/bash run_incog…"   2 hours ago   Up 2 hours   0.0.0.0:9334->9334/tcp, 0.0.0.0:9433->9433/tcp                                                                                      inc_mainnet
b35f535842ea   parity/parity:stable                          "/bin/parity --light…"   2 hours ago   Up 2 hours   5001/tcp, 8080/tcp, 8082-8083/tcp, 8180/tcp, 0.0.0.0:8545->8545/tcp, 8546/tcp, 0.0.0.0:30303->30303/tcp, 0.0.0.0:30303->30303/udp   eth_mainnet

add http(s):// to the domain name and port

This did not work. It does not give an error and does add a node to the app, but the keychain is blank. Also, is incognito actually using http? I wouldn’t think so.

Incidentally trying to add via the external IP address has the same behavior, no error but also not populating the keychain. Are there other ports that might need to be opened?

According to the devs, they do

1 Like

I figured it out, it’s my router. Basically android has an issue resolving external domains when you are on the local network. Turned off my Wifi and used LTE and bam it connected. To solve I created another subdomain for just this machine and configure it both for dynamic dns for when I’m outside my network and a host override for when I am on my network. Other’s have mentioned needing to forward 9433, 8545, and 30303 but I did not have to forward those, just 9334.

3 Likes