Tried to setup vNode with VPS running Ubuntu v20 = Docker issues

Hi there,
Love the community and have been saving up for my first vNode! Finally saved enough PRV and got my server up and running on Vultr running the newest Ubuntu (v20) only to find that Ubuntu 20 has many issues related to docker. I could not get docker installed and really couldn’t figure out the issue. Others were having similar docker issues with Ubuntu 20, so I reverted the server to Ubuntu 18 and works like a charm!

Hopefully this helps anyone out who’s frustrated with trying to identify why your server can’t run any docker commands! Just downgrade OSs and try again :grin: excited to be a part of this community and looking forward to working more with you all!


Hey @PRVhodlr, welcome to the Incognito community! :tada:

If you run vNode, recommend you to take a look at Although it’s less user friendly than Vultr, it’s still much less pricey.


Awesome - I will definitely check that out. Thank you!

1 Like

I’ve been running Ubuntu v20 on my vnodes without any apparent docker issues and earnings seem fairly normal. However, I’ve read on here that v18 is needed for stability. Is there something I’m missing or not looking at correctly? I run sudo docker stats and it looks stable.

Hi @JG20, previously it was hard to install the docker on Ubuntu v20 as @PRVhodlr mentioned above.
If docker stats and the instances are running fine, you are all set :tada: