[Supported] Unable to Buy (SWAP) for anything now?

I am unable to buy (SWAP) for anything right now (tried USDT -> BTC, LTC, ZEC, BNB). Just me?

I just did a test trade PRV > XMR and it worked for me.

1 Like

Still no go for me. I’m on Android and must have gotten the update because the font is a little different now. I did try the PRV > XMR swap you mentioned, and same thing happens. I put an amount in for PRV and it shows “required” in red where the XMR amount should show. Like it’s expecting me to enter both amounts, instead of showing me how much XMR I should get based on how much PRV I’m swapping from.

Please go into More > Settings and scroll down and let me know your app version. Also on Android here as well.


I restarted my phone. Did a “Clear cached balance” and “Clear history” … still doesn’t work.

Can you check again if you are still having issues?

Unfortunately still having the same problem…

hi @yoo could you please give me screenshot your error.

I chose the two coins (I want to swap USDT to “buy” LTC), then put 5 in for the USDT, then I tap on the 0 where LTC is and it normally would show me how much LTC I can get for that 5 USDT, but it says “required” in red (and won’t let me hit swap). If I choose an amount of LTC (say 0.05), it removes what I entered in USDT and shows 0 with “required” in red up there.

Hi @yoo

Is this happen to other pair or just usdt?
Make sure your balance have some usdt, then at Swap, please try to tap “MAX” then share us screenshot.
Look like your wallet have problem to estimate trade output

Same thing happens with every pair I have try, and swap screen shows 18 USDT balance (which is correct).

OK, your thought is correct - if I hit MAX it works - it does estimate trade output… Seems like that’s the case for any coin. I can’t try to swap less than MAX. (I don’t want to swap MAX though lol)

hi @yoo, sorry for late reply, we have tried several kind of phone models but can not reproduce this case.
Notice that, after input the amount to trade, you have to “enter” (commit) the value. In my phone it a :white_check_mark: so the app confirm value and start estimate the output

If the issue persist, can you try this on a different phone?

If not can you please help to backup all your privatekey and masterkey (12 words seed phrase) and your pNode/vNode setting, ip-address:port
After that go to Android System Setting/App, clear app data, cache, uninstall
Then install fresh app from google playstore, and import all account again


This works!! I had never done it this way (tapping the check mark on the keyboard) - I always just tapped the 0 for the second coin and it would estimate the output automatically then. Thank you for figuring it out!


A post was split to a new topic: trade help

A post was split to a new topic: Issue with trades

This is still a point of confusion (at least in the Android app v5.10.0).
I had the same problem as yoo, and couldn’t figure it out until I found this bug report. FYI, I was exploring swap from DAI to BUSD and CAKE to BUSD.
I know the UI development is constrained by the cross-platform tools being used, and this issue can’t be resolved easily … or else it would have been done by now.

But maybe you can find a way to at least improve the situation by 1) indicating to the user when the entered value has not yet been “confirmed” with the :white_check_mark:? For example, clear the entered value back to 0, … or display a “please confirm value” message and 2) automatically confirm the amount if the user clicks the “MAX” button (since they won’t even see the keyboard with the :white_check_mark:).

These changes would not be a proper fix, but I think they would reduce the user confusion and bug reports!

1 Like