Stake - Option in app to funnel rewards to a single account

@fredlee can you explain the withdrawing rewards process? I have two accounts (A & B). Account A funded the 1750PRV and gets the rewards. Account B is the validator. Account B has earned some rewards as seen in monitor details.

But on the Power and node details it shows 0. “Withdraw all rewards”. does nothing and I can’t see account A in the Power screens since it is not a validator. Can you tell me where the PRV are hiding? Do I need to do CLI withdrawal for Account A?

Yes, they’re on account A. There’s two options for you.

  1. Start it up as a node and add it to the power tab. You do not need to stake it or even keep it online after you’ve added it.

  2. Use the cli to withdraw.

incognito-cli withdrawreward --privateKey <funding_PrivateKey>

To check balance, you can do something like this in a shell script

reward=($(incognito-cli checkrewards --address <funding_PaymentAddress> | grep "0000000000000000000000000000000000000000000000000000000000000004"))
echo Reward balance: $(( ${reward[1]} / 1000000000 )) PRV

Awesome, Thanks for the clarification.

Is this no longer working @fredlee ?

I had a node get slashed and tried to restake using this process like i always do, same way, and it keeps erroring out.

Connection refused.

Yeah, incognito is having problems with their fullnode which unfortunately is hardcoded into the incognito-cli.

But if you already know how to build the cli from source, then it’s a quite easy hack until they fix it properly.

1 Like

hey guys, this fullnode is back online


I still get errors when trying to sync. However different errors then a few days ago.

Had to resync OTA key. Now it works

1 Like

Does anyone know how to unstake in cli a specific node that was staked using the above method?

I’m not familiar with the method in this post, however, any node will become unstaked if it is slashed. Stop the node in Docker and it will slash upon entering committee again.

But then I won’t earn anything. I want to earn and unstake

I never unstake so I have not tested it. But in theory it should be the same as staking.

incognito-cli unstake -privateKey <funding_PrivateKey> --miningKey <node_MiningKey> --candidateAddress <node_PaymentAddress>

1 Like

This worked btw


What is the correct way to do this currently?

./incognito-cli stake -p xxxx -rwdAddr yyyy

Says the OTA Key isn’t synced, but I’m not clear on how to sync it

That is because of the OTA (one time addresses) Incognito is using. The only way for a full node to know your balance is if you first submit your OTA key.

incognito-cli account sub --otaKey <OTA key>

Thanks, now the error is the total unspent amount is (0) when it needs to be 1750.1, there is enough PRV in the staking account.

I got the same error when I tried to unstake a different vNode.

Transfer the PRV to another account and then back in and you should be good.

Another step closer, now it says the error is -1016 Reject invalid fee and -1004: reject invalid fee transaction hash

Did you update cli? If it is old version, it creates txs with old network fee. So you should get the new release if exists or build it.

1 Like