Some Wallet Error Codes

Hopefully, everything will work smoothly and easy no matter what action you perform in the Incognito wallet App, but in case it errors here are some error codes, their meaning and how to solve the error.

Code When Cause Solution
1 Any transfer/trade Insufficient balance to cover the fee. Please top up.
2 General A request took too long to process. Please try again later.
5 Shows as WEB_JS_ERROR(-5) Insufficient PRV balance. Please top up.
8 General Firebase initiation unsuccessful. Please try again later.
9 General Network request unsuccessful. Please try again later.
10 Install Unable to generate keychain. Please try again later.
12 Withdraw Balance is currently zero. Please try with a larger amount.
13 Withdraw Unable to generate address. Please try again.
14 Wallet Unable to create wallet. Please try again.
15 Wallet Unable to load wallet. Please try again.
16 Keychain Creation Unable to create keychain. Please try again
17 Keychain Creation Keychain name already exists on this device. Please try another.
18 Keychain Unable to load your coin list. Please refresh your screen.
19 Keychain Unable to load your balance. Please refresh your screen.
20 Keychain Import Import unsuccessful. Please import a valid private key.
21 Keychain Import Keychain already exists. -
22 Node Node already added. -
23 Node Invalid Host. -
24 Install Unable to load your coin list. Please try again.
25 Node Payment address missing. Please import the associated keychain.
27 Login Login unsuccessful. Please check your credentials and try again.
28 pAPPS Invalid URL. Please try another.
29 Any transfer/trade Fee type is currently not supported. Please try another.
30 Adding Bep2Token Coin not found. Please enter an existing coin.
31 Adding Erc20Token Coin not found. Please enter an existing coin.
32 Node Firebase authentication unsuccessful. Please try again.
33 Node Code verification unsuccessful. Please try again.
34 Node Account creation unsuccessful. Please try again.
35 Node Unable to connect to Hotspot. Please power cycle the Node.
36 Node Withdrawal pending. Please wait for it to complete.
37 Node Unable to find WiFi. Please enter valid credentials.
40 pDEX Withdrawal unsuccessful. Please try again.
41 pAPPS Unable to open pApp. Please try again.
42 pAPPS This coin is not currently supported. Please try another.
43 Issuing Coin Image is too big. Please try a smaller one.
44 Issuing Coin Image is in the wrong format. Please upload a png file.
61 Removing liquidity pair from pDEX Insufficient funds to cover the network fee. Please top up.
65 Adding liquidity pair to pDEX Fee invalid. Please try again later.
1001 Any transfer/trade Unable to validate keychain. Please send a message to [email protected].
1002 Any transfer/trade Invalid timestamp. Please make sure the time on your device is correct.
1016 Any trade Invalid fee. Please try increasing it slightly.
3006 Any transaction Your keychain has so many utxos Please consolidate your utxos.
4005 Any transfer/trade Unable to load coin list. Please try again later.
6001 Any trade App update required. Please get the latest version from your app store.
6004 Any transfer/trade Unable to validate keychain. Please update your app.
6005 Any transfer/trade Previous transaction still processing. Please wait for it to complete before making a new one.
9999 Anywhere There seems to be an issue with the fullnode. Please contact us at [email protected].

wow. this is super helpful. thank you @Jamie!

@thaibao @binh can we add all errors here, the current ones and also the new ones that we’ll introduce?


I’m getting 1003, 1002 error message during PRV/pUSDC trading. I checked my device time stamp and it’s synced with the network. Can someone please help?

Can you set back 5 minutes and try again please?

That worked. Thank you @Peter.
Network latency or some other issue might be the culprit in this case. But incognito app definitely needs to take this into consideration as moving clocks by a few mins everytime is more of a hack than a solution.

Yes, we will look into it asap. Thanks for your feedbacks, Peacemaker.

Getting 503 (undefined) when trying to view my nodes in the app. Can we have this error code added please.

Appears to have been a small service hiccup. Nodes are now displaying properly in app.


All 500 codes are related to the server.

1 Like

I got this error yesterday and after refreshing it seemed fine, at first it worried me because I’m so new and was thinking “Great, I already broke it” :joy:


What about this “…(Web-JS_ERROR(-3006)” then going to PROVIDE PRV?

Hi @vafin, to solve this problem, please consolidate your account.
Here’s how: How to consolidate UTXOs

1 Like

Hi, Peter! It’s all ok now…) Thanks. bro)))

I have a transaction that says it was complete; I was just switching from PRV to XMR inside the app… It says that the transaction was completed, but then when I look further at the transactions it just says “unsuccessful” with no error code or anything. And my money is nowhere.

Hey @Cazilia, please send a DM to @Support with the details what happened to you (including a screenshot if possible). We will check it out for you.

Hi @Jamie, I am trying to withdraw PRV from Provide. I have been using provide since the begging and never have seen error message like "Opps! Something went wrong. The address haven’t staked yet (API_ERROR(-80010)). I tried more than 5 times with different values, but always get the same error. Can you help me ?

hey @pfrp, please send DM to @Support with the details what happened to you (including a screenshot if possible). We will check it out for you.

1 Like

I cant add funds/ or buy crypto?? I get insufficient balance and there is no option ti add funds??

1 Like

You can add your token from a public blockchain using the Shield feature.

I’m getting error code 522 (status code 522) when I try to view my assets.
Is there anything I need to do or is there a server problem right now?