[SOLVED] Withdrawal is stuck

Hey any online team member,

I closed the app before the withdrawal was completed. It was at %80. Currently, the send and withdrawal transactions don’t exist in my app. I found the burning transaction from the scanner. Here is the link: https://incscan.io/blockchain/transactions/5dafc0c6d37ce48984fdc8fd1329aab2a5ad16f0e7cbca4389d64084d9c91f7b

Source Incognito address: 12RqF7rJwH9f9p4ZD6yFK3LxK3cUuYymbdKnVN3NKok6LEAnFunQ4RLcCBbWJW6FFrgtHHpJHcjKCUrZxHWSmk7BysAFRJXtgrcMKTJ

I think it is stuck since the asset is in neither in Incognito wallet nor in the destination address. Could you transfer the asset to the destination address? Thanks.

2 Likes

@Peter @andrey @aaron

2 Likes

Hey @abduraman, let us double check it and get back to you.

1 Like

Btw, this type of situations mustn’t occur in a decentralized network. In every such situations, the community needs to access a member of the core team. However, a real solution would be that the funds should be either refunded to the Incognito wallet automatically or resent to the outer destination wallet automatically for the withdrawal case. For the deposit case, its reverse. Can’t the node software be implemented in this way?

2 Likes

Hey @Ducky, is there any progress?

Hi @abduraman , sorry i jump to you. Hv you checked on etherscan. At least to ensure, although there was no any withdraw transaction didnt exist on app. But you know the destination address for your ZRX token.

If there were no any confirmation history on etherscan. I am sure, bridging issue on incognito.

I just tested unshield token and closing app during 80%.
tx on scan.

And the token is arrive on my wallet

I did testing base on app sequence : tx fee , i set 0.1 PRV

30% closed app. result no any tx execution
50% closed app. result no any tx execution
80% closed app. result tx executed.

I am testing the 2nd time right now. Result will be updated here. As i wanna know if any bug. Because, every issue are very important to know by new user.

Updated:
Result : Stuck : 80% app closed.


The issue is bridging process are not executed but inchain is executed.
Indication as pic below:

Send & Withdraw history exist on app. Indication transaction are smoothly success.
If Send only "exist "on app and there is no withdraw history ( Red circle ). Indication that transaction is stuck inchain. It seem core dev team to notice this issue.
2nd failed tx

@Peter please noted. @abduraman you are right. Highly appreciated to arise this issue.

This issue is inconveniences for user.

1 Like

Hey @abduraman, our dev @phuong helped you process it already. Can you double check again?

1 Like

Yes, solved. Thanks.

@Trader3 @abduraman thanks for bringing this to our attention.
Currently, the tx is stored locally on your device. When the process is complete (100%), your device will push that tx to our server and the withdrawal will start going out of the Incognito network.

After discussing Abduraman’s advice, this is our solution:
1/ Funds is refunded to the Incognito wallet: This is impossible as your token is burned. Despite the fact you can’t see the TX on the app, it is visible on the network and we can’t revert this transaction.

2/ Re-send to the outer destination wallet: To do this, we need to make some changes: Have the app read/ get the Tx directly from the network, then map with the server to retry the withdrawal automatically.

It will take time. Meanwhile, we will change this message from “Please wait, this window will close when complete” to"Please wait, don’t close this window until it completes" so the tx can fully store in your local device.

4 Likes