[Solved] Withdraw button in Provide

In new Provide app, why is withdraw button replaced with buy crypto button? How do I withdraw rewards?

I’m using the latest version of Incognito currently available from the Android Play store - Provide works the same as it did prior to the update for me. Open the app, tap the three lines at the bottom right of the screen (says More), then tap Provide (top left icon) on the next screen. This screen looks nearly identical to the old app, with “Withdraw” and “Provide more” buttons near the top.

I’m on iPhone and it is not like before and no withdrawal button. I uploaded new app on on Jan 2. It worked fine and had withdraw button. Now the withdrawal button is replaced by buy crypto button that takes me to purchase page. Scary!

Iphone8

Yep, can confirm this on iOS. @support please advise the devs that iOS Provide screen has a Buy Crypto button where the Withdraw button should be.

EDIT: Android also affected:

Affected app version on both iOS and Android is v5.0.8 per Settings.

@Dew, @Mike_Wagner you see the screen (with Buy crypto button without Withdraw) is because you haven’t provided any coins to the Provide yet. Once you provide at least one coin in the list, you will see a Withdraw button to withdraw your coins.
Also, if you have provided some coins, please check to make sure you are on the right account.

Thank you Duc. I have no assets in wallet because they are all in provide. I have requested PRV from faucet and will keep something in wallet to activate withdraw button. This needs to be addressed. Thanks again.

“Buy crypto”. It’s like you want it to look like a scam. :joy:

@Dew Did you double-check that you’re in the correct keychain? In your screenshot I see the spinner next to the amount, does it change to a document (view history) after a while or does it just disappear?

Edit: Oh, sorry, I might have misunderstood. So the withdraw button appeared when you had non-provided funds in the wallet?

@duc Are you getting rid of the provide interface? (I hope so.) If not, I got some comments on the page design.

Thank you Fredlee for your comment.
To clarify current issue. I have had many coins in Provide account for months.
Also I have only one account.
Yes the spinner just keeps spinning and does not stop on opening Provide screen.
I have transferred some BTC to wallet to see if that will trigger the withdrawal button.
As it stand now I have no access to funds in Provide and can not withdraw PRV. Please advise.

Ah, that’s what I first thought, but then I saw the issue marked as [solved] and thought you got withdraw back after using PRV faucet.

If you click the key in the corner, you only have one keychain? Not the old pDEX, pDEXWithdraw, or anything?

Spinner should stop (It takes a while tho) and either show a history icon or just disappear if you have no history. That’s how it works on my different keychains.

If you’re in the correct chain and/or the spinner never stops then @Support must clearly take a second look at your issue and mark this topic as not resolved.

Hi @Mike_Wagner @Dew

It will take a few seconds to load provide history, please make sure your network is stable and not using VPN.

Did you double-check that you’re in the correct keychain? You can DM me your address, I will help you check.

1 Like

Yes, thanks for having comments for the Provide, please add them to your awesome topic, it’s easier for us to collect all feedback there.

I deleted and reinstalled app from App Store. All seems to be functioning well now. Keep up the great wallet.

1 Like

Reinstalling the app is not a good solution we wanted to support (and recommend) you with the issue but it’s good to know it’s working now. Allow me to mark the post as solved, feel free to contact Support team if you need any further assistance, thanks.

2 Likes

I have the exact same problem and nothing has changed even I reinstalled the app. I can only see “Buy crypt” or “Provide now” buttons, even though I should have provided amounts of coins before. Any help?

Please check your other wallets.

I believe I only have one wallet. Where can I check it?
on the right top corner?

Yes on the top right corner. Click through any available. Also check your master seed.

I only have one account there.