[Solved] Why are my trades (swaps) failing?

I have been trying to swap DAI for BTC since last night, but all of my trades (swaps) are failing. The latest one was ~ $1.617 DAI for ~ 0.00003 BTC (why doesn’t swap history show the exact [FULL] amount?). When I calculated the price I was willing to pay (I upped slippage to 2% because of the prior failed trades), it was close to $48,000 - when BTC was trading around $47,000… Swap history shows “Rejected.”


I apologize for any inconvenience this has caused you.

The trading fee is paid by PRV, which is why your trades are rejected (it shouldn’t be, but it happened due to a bug in the app).

There is a way to get around this. Choose Advanced under the Swap tab, and choose “DAI” instead of “PRV” for the Trading fee token. Press the Swap button.

Please try it again in the way described above and let us know the outcome.


Thank you - that did work.

1 Like

The issue that allowed user to choose disallowed token for trading fees was fixed then im marking this as solved.