(Solved) Vnode issues

Some questions and issues from trying to setup my own vnodes. I followed the ‘setup your own node in a blink of an eye’ instructions. I created a new master key and 3 keychains under it, 1 for each vnode. They all show online in the node monitor and I added all three to my app. Confirmed the validator key from the 3 keychains are correct. All 3 prompt me to import the keychain but when I do, it says the keychain already exists. I’ve removed and re-added and I opened ports even though most seem to say it’s not needed. I tried to add after opening ports and it still says import. I removed and re-added one via local IP and still no go. So I have 3 vnodes added last weekend on 3 different VMs with 3 different public IPs and all are prompting to import.


What ports are you using? Does an online port scanner show them as being open?

Using the standard port, 9433 as they are all in different locations/public IPs. Verified 9433 is open via canyouseeme.org . Originally added them with just IP which defaulted to 9334 but removed and added with 9433 and am still prompted to import

Ah, you want to use the other port when adding them to the app.

So right now for one of the nodes I have 9433 and 9334 port forwarded for both TCP and UDP. 9433 confirmed open and 9334 refused via port scan. Added the vnode with both ports and both are prompting to import. Trying to import the keychain says it already exists on this device.

what does docker ps show?

Swipe that node to the left and delete it via the power screen. Re-add it using the 9334 port.

f99b836780e0 incognitochain/incognito-mainnet:20220701_2 “/bin/bash run_incog…” 32 hours ago Up 32 hours>8334/tcp,>9433/tcp inc_mainnet_0

Added this node both via local IP and public IP and both entries prompting to import.

Seems like a port issue. Make sure your config has the port open. Once accessible publicly you should see a stake button in the app.

I suppose it could be but I understand how to port forward and canyouseeme.org shows it as open. To test, I just spun up an instance in Vultr, no firewall and I’m having the same issue. Adding the node just shows import. Any other thoughts?

You’re using the validator key, right? No spaces or weird characters when you added it to the script?

You can use
docker inspect inc_mainnet | grep Env -A20
to check your miningkey (validator key).

Yep. Made a new keychain, pasted the validator key into the blink script when prompted. It shows up in the node monitor using the public key so I think that means the validator key is correct.

The docker inspect command doesn’t return anything but the /home/incognito/validator_keys is correct. (docker name is inc_mainnet_0)

Would you like to do a remote session in about 30 minutes from now?

If so, please download either TeamViewer or AnyDesk and send me a PM with the connection details.

Will do

The resolution was I was using the wrong port. I was using the node port instead of the rpc port. Port forwarding the rpc port and then using that when adding the node in the app worked.

1 Like