[SOLVED] USDC sent and address expired by the time it arrived

I recently sent myself some USDC coin so I could set up some nodes to support the community. Unfortunately, due to the delays enforced by the exchange, the coins arrived after the privacy address expired.

Is there anything I can do to gain access to these coins?


Hi @George, no worries. Please send the required information to @Ducky, so she can help:
1/ A transaction hash of your transfer
2/ A screenshot of the expired shield request on the Incognito app
See also: All you need to know about shielding your crypto!

Update: I got your information.


Received your private message @George :relaxed:


Solved! Thank you guys. I really appreciate the help.

It seems like this is a common issue - is there a known best practice to prevent this kind of mistake in the future?

If yes, I’d be happy to write up some documentation for folks looking to get involved in the community :slight_smile:


Hey @George, some more users are telling us about this issue. As always, we listen and our devs are also working to figure out a new way for shielding process that may help prevent the current risks like: expired, double-shielding to the same address…Those things happen could make users feel nervous haha )

But it’s still in our working now. It’s not easy I think. We will let the community know once it’s figured out.

Also, thanks for the idea of preparing instructive documentation for everyone to get involved :smiling_face_with_three_hearts: