(Solved) Unable to nuke and restart a node

I have a server with multiple nodes. node_data_2 which had been online for days stalled.

  • docker stop / start no change
  • bootstrap to re sync beacon and shard data no change
  • attempted to nuke the whole thing and restart with blink.sh - it didn’t populate that folder with anything but the rest of the validators seem to be fine.

So currently it is offline and only it’s root ‘node_data_2’ folder exists.

Not sure about next steps @support, I’m hoping to avoid having to nuke everyone to get this back online. I have 8 epochs to do it.

You have any other node on the same shard (or a full node)? In that case you can copy the node_data_* folder over from the working one.

Not sure why it wouldn’t start syncing if you start it with an empty data folder. Did you check the .log files for errors?

there’s actually an “.error” file in the node data folder. Can you show us that?

@Josh_Hamon please bootstrap data then ping me on telegram, i will try to get setup

I removed all files, so no error file available

A second bootstrap seemed to have solved the problem. Does the node monitor check the nodes themselves or blockchain? ie. Do I need to be more patience and wait for the updates to come from the blocks?