[Solved] Seemingly random API errors in Provide

Whenever I attempt to withdraw Provide rewards I get in red:


This message appears to come and go and tends to stay for all attempts over a few hours.
This bug effectively freezes the rewards.

Hello @m-mp,

Sorry about this issue. I’ve pinged a dev that deals with the app design and asked them to answer you regarding error -80015.

1 Like

I’ve also noticed that at the same time the attempts to provide more result in either:



Something went wrong. Please try again.
1 Like
  1. Please check the internet quality. Make sure the internet quality is stable.
  2. If you have just submitted a transaction, you must wait for the previous transaction to be successful before submitting again.
1 Like

Hello I have been receiving this same error when trying to withdraw my rewards from Provide for quite some time now (aka trying over several different times over a period of at least 1-2 weeks or more).

Is there any other known fixes for this? I do not have any other transactions pending at the same time and my internet quality/connection is very good (however I have changed my wifi router about 2 months ago just for context maybe relevent?)

Hi, can you tell me the error detail?
So, you can check the app version, make sure it’s the latest version.
and you also try to change another network (3G, 4G …).
Thank you!

The app version is up to date and here is a screenshot from yesterday with the error specifics

The error code: -80015: RecaptchaInvalid.
So you can check your google service on the app or change another network then try again.
you also try it with the another phone.

1 Like

Hmm not sure what happened but I tried again today when I woke up and it worked fine! Sometimes I have had this error before and just waited a day or so but this time specifically I tried over several days spanning to a few weeks and it just wasn’t working which is why I came over here. Thanks for your help!