[Solved] Provide Rewards withdrawal taking a long time

I’m running v4.7.3.

On the 9th of November at 9:45PM UTC I attempted to withdraw Rewards from Provide.
It is currently the 11th of November 8:25AM UTC and the reward withdraw is still pending.

I’d like to point out the UI suggests the user ought to wait a “couple of minutes” for their balance to update. At this point it’s been a couple of days. In the past these operations have taken at most 12h for me.

EDIT: As of this edit my withdrawals have been completed and the issue is solved.

1 Like

Hello @m-mp,

The text “balance update” just implies you will be able to see the amount be removed from the shown / stated balance.

Please note, reward withdrawal times can vary. Please provide me with your TxID

Also in same situation with two withdrawals on Monday morning. I can’t find TxID or transaction on incscan. I’m asking for direct help please. I see mention of a que. is this public so I can check status based on token quantity?

I have had this problem a couple of times now! I have just restarted the app after a couple of hours, and everything is where it should be!