(Solved) Problem withdrawing rewards from physical nodes

I’ve been having problem withdrawing rewards from my nodes (green light, fully functioning) for like several weeks now. Anyone knows why this is happening? Thanks!

When you attempt to withdraw wait a few seconds, if the screen displays a red box with an error message then most likely you need to have a small amount of PRV in your wallet to cover the network fee for the withdrawal.

You can add a small amount of PRV or request some from the faucet. Faucet.incognito.org

1 Like

I still have problems withdrawing from my nodes. I saw like 70 PRV from two nodes … so I clicked “withdraw” and the message “process initiated… balance will be updated…” appeared but nothing happened!! I did this so many times over so many days … same results! Sadly, it was super easy before but now is super difficult to do. Anyone knows what’s happening? Thanks!

Is this for a pNode or vNode?

What version of the app are you running (find it under settings at the bottom of the page)?

Please also go and click Clear Balance Cached under settings and then close and reopen your app.

v4.7.0 pnodes

Go under the power button on the home screen and let me know their status.

All green light

Please try going into each node and withdrawing one by one. Also watch for any error messages to pop up.

Apparently I don’t have enough PRV to perform this transaction and was advised to get it from the faucet!!!
Can you explain to me why I can’t spend my own PRV and have to beg from a faucet???

Ah, this is what I had initially thought was the case.

The faucet is just a fast way of doing it. You could have moved a tiny amount from one of your own wallets into this wallet.

Node withdraws now require transaction fees being they are on network transactions. I’m going to go ahead and mark this as (Solved) please let us know if you need any further assistance. Thank you for being an Incognito Node Operator.


I went to the faucet and asked for PRV and was successful several times. However, the problem remains… same error. Frustrating!!!

What is your ValidatorMiningPublicKey? You can find it on your pNodes dashboard (port 5000).

1 Like

Hi Jared, never mind. I got it to work already. Thanks for your help!!!

1 Like