(Solved) pNode died after power cycle

Hi all,

this morning I recognized a “Beacon stall” on my pNode and power cycled it. After plugging it back in there was a 3 seconds “screeching noise” and now the node is dead. Plugging the ac adapter in does exactly nothing…?!

Is there some way to revive it or can I consider a hardware worth a few hundred bucks dead after a few months?

Thanks for any advise…

Hello @scooter,

Sorry to hear this has happened to your pNode! :worried: :neutral_face:

Where did the screeching sound come from? Was it the power adapter that plugs into the wall or inside the unit?

I’m sure we can get to the bottom of your issue and diagnose what went wrong. For future reference, there are steps you can do to reboot the node without touching the power cable which can be found in the Official pNode Troubleshooting Guide.

1 Like

Hi Jared,

thanks for the quick response. It sounded like the noise was coming from the node device, not the power adapter. The LED turned blue after plugging in the adapter, then the noise appeared, and it died completely (LED off -> device dead). The noise could have been something like a broken fan. However that would be strange as it was running at normal noise levels the whole night (the node was elected and produced blocks during the night)… So it would be a strange coincidence the fan dies this morning.

Let me know if there are any other ideas on how to investigate. Next step would be opening the device with the screws on the bottom. However unless it’s very obvious I won’t be able to locate a technical problem by looking at the disassembled device anyways :smiley:

I’m really hoping it was a power supply issue as that can be replaced easily.

I actually do not have a pNode device myself so my diagnosis will be a slight shot in the dark. Is there any type of power indicator LED on the power supply itself? If there is you can try plugging in the power supply without plugging in the pNode to it and see if the power indicator lights up.

Did you notice any smoke or does anything smell burned? With everything unplugged try smelling both the power supply and the pNode separately. If you do there could have been a short in the motherboard PCB or a burned-out component.

In the event, it was just the fan that malfunctioned you should still be able to get the pNode to boot. Although not recommended to run it for a long time without the fan for testing purposes you can try.

If the board had a popped capacitor this is replaceable by someone who knows what they are doing and has skills/equipment to resolder a new cap.

Nope, no LED on the power supply unfortunately. Both the power supply and node smell normally, no smoke. Power supply is warm when plugged in but also seems quite normal to me…

@Support Any ideas? Or can I just throw the pNode in the trash?

hello @scooter,

when did you buy this pNode? is it still under warranty?
what is the pNode ID (QR code at bottom of the node)
if it out of warranty, you can unscrew to open this, plugin HDMI and keyboard/mouse to check

you can ping me on telegram for quick support https://t.me/khanhj


Quick update. It was the power supply only that had died spontaneously. An original Intel NUC power supply worked perfectly fine and the pNode is back online… Thanks again!


Wow, that’s really good to hear.

I’m going to mark this as (Solved) please let us know if you need further assistance.

1 Like