[Solved] Pdex bug (loss of user funds after a trade)

Pdex did not deliver two of my trades after successful confirmation of them , other users are also reporting same issue. This is resulting in either
A) A loss of user funds

B) A UI glitch with the wallet not displaying correct balances

I have verified my balance post trade with rpc calls using my viewing key and it seems the funds were not delivered after the pdex accepted the trade (delivered to my wallet)


If this is indeed not a ui glitch I highly sugguest haulting trading until this is fixed.


Here are the trades that executed and never got sent to my incognito wallet:

Incognito Transaction 03980d88cec077f8c9737b78659482b75d6715617bb2ac9a977bbd4abf9594cf | Incscan.io

and here

Incognito Transaction cfbfd75a93d76d50e64b617b926bfab42226cb9ff6784f72ff981b49c6a8d7ec | Incscan.io

1 Like

I believe this was discussed in the past. If my memory serves correct it is only a UI bug and nothing to be worried about.

Should be added to the future app updates to work out a way to check transactions after a set time period (say 30 minutes).


Hey @Matt6412, I believe that devs retried the trading transactions for you. You should get your funds shortly.

If you still don’t receive your funds within today, then pls send us a direct message with your trade ID.


Okay, thanks ducky. I got one txn returned, still waiting on the other. kinda want to go through my list of trades today and make sure everything adds up. Ill keep you posted


The txn returned so far is the 0.145147255 pBTC . still waiting on the 16970.21037 pUSDT, but I know you guys are working on it)

Got the usdt back. ty for the help. hope whatever caused this is fixed cause I am a bit nervous trading now heh.

This actually was not a UI bug, the transactions were never delievered post trade to my wallet. Confirmed over rpc calls w/ fullnode ; the transactions are logged in the network explorer being sent to me as the dev team “corrected it”

1 Like

Hey guys! To follow up on this issue.

Some pDEX trades were rejected. Causing subsequent trades to also be rejected. A few users experienced funds not returned after an unsuccessful trade. Our devs have pushed a fix through new code which will auto-retry your trade after it was rejected so you will no longer experience unsuccessful trades where funds are not returned. Instead, the trade will be retried a few moment later.

-Hope that helps clear it up a bit.


My 2 trades as documented in the network explorer links above did not fail. They returned trade accepted. Whatever ever function of the pdex that sends the user the funds post trade, did not work. I tried locating the code for this in the pdex, as me and @Revolve were discussing (in the discord community) the inner mechanics of a trade in respect to roundtrip between user wallet back to user wallet (including all the state changes) So whatever bug the devs think they fixed might not apply to my scenario.

If im missing the code somewhere , could someone point it out for me? For instance, where did my pcoins go when they did not get returned to me? Is there a pool that holds trade swap coins during a trade? if so, who has access to this pool? ----> is it in fact decentralized like the original concept engine built for uniswap?




hey @Matt6412, please look into the post to see how it works right now and what we will be able to improve with one-time address: One-Time Address - Improve on privacy and pDEX performance
If you have any further questions or concerns, feel free to leave comments here, love to have a conversation with you as always.


Hi guys, I think it is happening again. I have traded at 3 am GMT using sdk. Trade was submitted with success but wallet shows no funds now. I restarted the program and my log file was overwrited, so what can I do ?

Hi @Peter, I posted here as you have asked on telegram.

Thank you,

1 Like

hi, @pfrp should you give us your tx trade ?

Hi binh, the funds was not showing using js sdk, but using incognito app the funds was there. Is it possible to read past transactions using the sdk if I did not save them localy ?

1 Like

Hi @binh, it happened again. Today I have traded using Incognito App and the trade took to long and was unsuccessful, but funds did not come back. Trade ID: 60322 at 08 mar 2021 12:02 PM.

Can you help me ?
Thank you


Hi binh, the funds was not showing using js sdk, but using incognito app the funds was there. Is it possible to read past transactions using the sdk if I did not save them localy ?

For this, because ‘send’ records are stored locally,
it’s impossible to read ‘send’ history if you don’t send via wallet.

For trade got lost: please wait a bit more patiently, we will double check.
Sorry for this inconvenient experience!

So this bug is still not fixed it seems. Also my bug resulted in funds not being returned after 2 successful trades and no report was made saying saying solution was found (cause of bug and fix, obviously the devs manually returned my money since I provided proper citation of trades).

With both of these being said, why would any user dare risk using this app to trade until this massive bug / bugs are fixed ?

Hi @binh, the funds are back. Thank you. Does the team have an estimated date to fix this bug ?

we will release a hotfix to improve and fix this issue in next week.
Please wait.
Thanks alot.

1 Like

Hey @Matt6412, pDEX does not have such a risk. The chain works well. So funds are SAFU. The problem is about the app (client side). In other words, the funds are in the user’s wallet but the app cannot show them correctly.