[Solved] How to run a testnet fullnode?


I tried to run a testnet fullnode (to prepare Incscan for Privacy V2).

Unfortunately, It doesn’t start.

What I tried:

  • cd $GOPATH
  • git clone https://github.com/incognitochain/incognito-chain
  • go build -o incognito
  • ./incognito --testnet true --nodemode "relay" --externaladdress "" --enablewallet --wallet "wallet" --walletpassphrase "12345678" --walletautoinit --norpcauth --datadir "../testnet/fullnode" --discoverpeersaddress "testnet-bootnode.incognito.org:9330" --norpcauth --rpclisten "" --rpcwslisten "" (from https://github.com/incognitochain/incognito-chain/blob/production/run_node.sh#L96)
  • and GO111MODULE=on ETH_NAME=kovan.infura.io/v3/1138a1e99b154b10bae5c382ad894361 GETH_PROTOCOL=https GETH_PORT="" ./incognito --testnet true --nodemode "relay" --relayshards "[0]" --externaladdress "" --enablewallet --wallet "wallet" --walletpassphrase "12345678" --walletautoinit --norpcauth --datadir "../testnet/fullnode" --discoverpeersaddress "testnet-bootnode.incognito.org:9330" --norpcauth --rpclisten "" --rpcwslisten "" (from https://github.com/incognitochain/incognito-chain/blob/production/run_node.sh#L99)

These 2 commands I tried end with panic: runtime error: index out of range [4] with length 4.
I know it’s related to keylist files but I can’t find a valid setup that works for testnet.

Any help appreciated! Thanks.

1 Like

We’re currently having 2 testnets (1 & 2) that are being run by code on branches:
development and release respectively. So if you wanted to run your own testnet from source code then you should clone from these branches (You are now cloning from production branch)
Regarding the keylist files, please look into /bin/build.sh, /bin/build-testnet2.sh and /bin/build_mainnet.sh from the repository to see how to use keylist files for each environment.


Thanks @duc !

I’ve built a testnet docker image by using bin/build-testnet2.sh script on release branch.

Now I’m trying to join your testnet-2 by using bootnode testnet-bootnode.incognito.org:9330 and i’ve another error when the node tries to sync. Here is what I see in logs:

beaconchain.go:198 [INF] BlockChain log: BeaconBlock 2 link to wrong view (8aefa2963a5cd44d5c47c227004468b3e3a9f7f171aa60e8c899bab59c96008c)

I’ve searched for an alternative bootnode in your repository but I found only testnet, mainnet and devnet, nothing about testnet-2.

ah please try with the bootnode (, this one is for testnet 2.

1 Like

Perfect, synchronization in progress :+1: