[Solved] Faucet error. Please try again.

Hello, i’m very new to incognito app and i’m trying to get some PRV coin to execute my first transaction. From what i understand, i need to use the “Faucet” feature.
After solving the hCaptcha puzzle, i click the “Give me PRV” button and everytime i get the “Faucet error. Please try again.” message. And if i click again on the button, the message changes for “Robot verification failed. please try again.”.
I’m not really sure what’s going on.
I added a screenshot of the first error.

Thanks for you help.

Hello @jimbo,

First off, welcome to Incognito, we are glad to have you here.

I have relayed your message to the devs to ask them to look into this issue, it is not the first impression we hoped you’d have.

If you give me your full address I can send you some PRV to get started.
(the one in the screenshot is truncated)

1 Like

Hello fredlee, thanks for the suggestion.
Here the full receive address:


Done, you should have a couple of PRV now in that account.

I confirm reception. Thank you.
Does the Faucet function works for you?

It does, tested right now. Did you try again today?

I made another attempt couple of minutes BEFORE you sent me some PRV and it failed as usual.
And I made another attempt AFTER you sent me some PRV and it worked.
Could the problem be that the Faucet wont work if you have no PRV in you wallet? That would be strange but things points to that direction. Just an hypothesis…


Tested a new keychain with no assets and it still worked, so it was not that simple. Maybe there was a temporary error with the faucet function? If not, maybe it needs more testing with a brand new installation on the platform you’re using to make sure there’s not an issue for all new users.

Maybe @Support has any info?

1 Like

Thanks for reporting the issue, we are double checking our service

1 Like

The faucet getting empty on some accounts.
This has been fixed.