[Solved]Cant add virtual node on app

Pressing the “add” button on the app after typing the ip in, with or without the port just highlights the button - I hope that makes sense

I would recommend you to create another key / wallet in the app named Node1. Copy the validator key and put it in the install script before running. You’ll want to transfer your 1750 PRV. I usually transfer 1750.5 PRV to my node wallet to cover the small fees. If you have staked your PRV in the meantime then you’ll have to wait to withdraw it as withdrawing from stake can take a few days.

Port 9334 on IP address is showing as closed. Are you sure the script ran correctly?

I tried the IP:Port you listed and it is the actual one then there is something wrong with the config of the VPS because the app is not about to connect to it.

1 Like

cheers - I have 1800PRV ill set it to leave the staking, i had since destroyed that server and started again - can you drop the deploy script here for me incase im somehow putting my Validator key in the wrong place

Follow this script. That way if you want to add another node in the future it’ll be easy to do.

Edit the script with “sudo nano” before you run it and add in your validator key.

1 Like

If you can’t figure it out I can help walk you through it. I can assure you it works on Vultr because I used to use them but now I use contabo.

1 Like

I appreciate the help, very new to the coding so sometimes white out over it haha so its 99.99% me messing up - just ran the scripts and it already seems to be doing more pulls than before so I must have messes something up - set the withdraw from the Provider stake so will see if its running once this is done then try with the PRV back in the main wallet. Expect some more cries of help in the next few days though haha

Awesome. If you’re seeing more pulls when it’s setting up docker that’s great. Go ahead and try adding the node again in the app after you make a new key for your node. You can always add the stake later on but can setup the node now to make sure it works.

Check sudo docker stats and sudo docker ps to see if your node is running correctly and check the port again as well.

Still nothing when I press add >_<
getting this on docker stats
6eddc581fe31 inc_mainnet_3 0.00% 0B / 0B 0.00% 0B / 0B 0B / 0B 0
91b71da6435e inc_mainnet_0 178.38% 389MiB / 7.789GiB 4.88% 61.2MB / 658kB 0B / 0B 18

and this on Docker PS
6eddc581fe31 incognitochain/incognito-mainnet:20200807_2 “/bin/bash run_incog…” 7 minutes ago Restarting (3) 30 seconds ago inc_mainnet_3
91b71da6435e incognitochain/incognito-mainnet:20200807_2 “/bin/bash run_incog…” 7 minutes ago Up 7 minutes>9334/tcp,>9433/tcp inc_mainnet_0

Checking on the telnet web tool it is accessable - Connection Status : Connection to on port 9334 was successfull

Gonna have to crash out as im about to hit 3am and feeling defeated haha

Okay so according to the logs for some reason the docker container looks to be restarting over and over again and again. Which VPS did you pay for?

Also you want to check the IP address on an external website. Use the following website to check your port from now on.


Did you follow this guide when you setup your Vultr VPS?

Yeah followed the guide - the only variance is that there no longer seems to be 19.10 x64 so selecting 20.04 x64
Cheers for the help I appreciate it!
Just so I know Im doing it right, once ive edited the code in Sudo nano is there something specific I need to do to deploy the code as i could be doing that wrong somehow - im sure id be able to find a way!

It may be that something is broke with incog network.
We are seeing restart issues as well with nodes that have been working fine.

Hi @Bazz_Jeffries, please restart the app, and confirm that the IP you want to add hasn’t existed yet on your Node screen.

Currently, we can’t add 2 Nodes with the same IP address. It will give an error message, and it was hidden behind the keyboard. We will improve this glitch soon.

@Peter @Bazz_Jeffries was having an issue with his node starting up. He has since spun up a new VPS and it appears this node is working without restarts and the port is showing open on a port checker.

1 Like

Hi Peter thanks have restarted and tried again but still not working here’s a screen capture of what happens if that helps

1 Like

Thanks @Jared. “Restarting instance” is a different problem. I think we need a log to verify.
Hi @fitz_fiat & @Bazz_Jeffries, please give us this file so we can verify: error.log It is in your /data directory.

Another thing that we are working on is that you can’t add a node to your screen using the IP. Please wait for our updates.

1 Like

I also meet the same problem.

My app wallet is on ios.

My ubuntu version is: 20.04

Hi @Bazz_Jeffries @leo,

Have you ever had any added Nodes in that screen? We are trying to reproduce the bug.

Also, please try to add again now and let me know the result.