[Solved] BTC Shield Timed out, app fails poorly

A couple hours ago I tried to Shield some BTC. I saw a transaction pending at the source and in the Incognito app. I opened app again later to check and got an error 523 message:


Then I restarted my phone and got this timeout message


I checked again a few hours later, saw the transaction never went through, and my BTC was still at source, so I’m relieved I didn’t lose it. But, the app could handle this much better. Those error messages came up as soon as I launched the app on my phone, and prevented me from doing anything else. Trade, Provide, Quest, nothing was available because something weird was going on with the shielding BTC transaction. Also, glad I disregarded the error message advice to reinstall app and just waited. This is on an Iphone 6 running ios 12.4.8 if that helps.

1 Like

Thanks for your message, @Rekonn. The app was having a problem with the fullnode at that moment. The network itself is still fine and all are back to normal shortly.
We are going to change the message to make it clear and informative. Let’s shield your BTC again, but I wonder why your BTC wasn’t leaving your source at that moment. :thinking:

1 Like

Maybe the app can be updated to do a fullnode check when the user clicks on the [Shield my crypto] button? Seeing a message like “Shielding currently unavailable, check back in 15 minutes” would be MUCH better than starting a transaction, and having to wait for it to fail while not being able to do anything else in the app.

1 Like

I attempted to Shield a little DAI this morning from my Celsius account, and after about 2 and a half hours, that timed out. Is Shield still broken?

This transaction behaved much better, btw, was still able to do other things while this one was happening.

Hey @Rekonn the error message you received on the app is not related to the BTC shielding transaction, this was due to a hiccup with the app itself, it is not tied to the shielding transaction.

Shielding is working as expected, you should always be able to do other things while the shield transaction is pending. Could you check and see if you are on the latest app version?

1 Like

It’s v3.10.6

Btw, Chucky solved my DAI problem, I just didn’t have any ETH to pay the gas fee, duh.