Setting up a vNode Validator on UnRaid. Has anyone done it?

Hi All,
First off, apologies if this has been asked and answered somewhere else. I did try looking but couldn’t find anything.
I’ve been looking at trying to setup a validator for a little while. Originally tried to see if i could find an old pnode to buy and reset but that doesn’t seem to be an option.

So my next choice was to try and setup a vnode on my own computer. I need to admit at this point I’m not very adept on linux, much more used to windows.
However I run UnRaid at the moment on my machine and create a virtual Windows instance for my daily computing.

I’m wondering if anyone has created a vnode on a virtual instance of Linux and would have guidance on some of rhe setup?

Or I see a lot of talk about dockers, and unraid itself let’s me run what it calls dockers that to what I can understand are self contained programs run directly on the unraid server. So would it be possible to run a vnode validator as one of these docker instances directly on unraid?

So far, with having not a lot of knowledge around the above, I have attempted to setup the vnode on the windows virtual machine so far, and it seems to start as some sort of service but I can’t find anyway to get my mobile app to recognise the node. I suspect I’m doing something wrong with opening ports or redirecting traffic. Is there some troubleshooting options I can run to try and figure out what is going wrong?

I’m hoping if there is a way to run it directly from unraid too, then this could open the running of nodes to a whole new group of users running unraid?

Appreciate any help people can offer me.



Hello @ftdhwbnaic,

The recommended setup is with a Docker Container. The easiest way to get this docker container running is by following our guide found here:

How to setup your own node in a blink of an eye (Now support multi-nodes per host)

Docker containers can be ran on almost any system that supports them as a docker container has all of the dependences and software prebuilt in.

Hi @Jared

Thanks for directing me to that walkthrough.
I have just attempted to run through it again, and I’m still getting stuck.
A couple of queries if I may
a) when setting up the infura account, it mentions getting the mainnet api url in settings. when I login to infura, settings has no information, however I do go to the endpoints tab, and have multiple URLs to choose from, the Ethereum address appears closest to the example so I have been copying that address. Is this correct?
b) trying to get the process started on unraid, (fair warning, I understand I may need to await help from the unraid community on this one, but someone here may know?) I try the community applications plugin, but it doesn’t appear anyone has created one, so I attempt to create my own container. In the instructions I’ve found on unraid, it refers to entering a repository for the docker which should be something similar to “eg. homeassistant/home-assistant:stable” so I’ve been trying to use incognitochain/incognito-chain but it currently throws an error of
“Unable to find image ‘incognitochain/incognito-chain:latest’ locally
docker: Error response from daemon: pull access denied for incognitochain/incognito-chain, repository does not exist or may require ‘docker login’: denied: requested access to the resource is denied.”
Does anyone know what the correct “repository” would be to install this vnode?

the other instructions from UnRaid im trying to follow

Thanks again for any help offered.

a) It appears Infura has changed the UI and now you can find the link under the enpoints tab. You’re correct that you need the Ethereum Mainnnet Link.

b) I’m not familiar with unraid but the repo they are most likely pulling from would be Docker Hubs. Here is the link to our Docker Hub:

Try this: docker pull incognitochain/incognito-mainnet

Hi Jared,
I’ve progressed further with setting up the vnode.
Now I appear to have a semi operational Node running on my own VM Ubuntu instance on my home computer.
Checking the online node checker tool it says its online, however I am struggling to get my incognito app to see the node correctly and allow me to stake.
It keeps asking me to import keys when I click on the node and then reminds me I already have that key assigned to my wallet when I try to import.

I have noticed the app seems to point to a non standard 9334 port instead of 9433.

However during the setup I used 9433 as that seemed to be default.

Is there any way to troubleshoot why my app can’t connect to the node?

I’ve tried checking open ports to the internal ip address on port 9433, my external ip address 9433.
I’ve created port forwarding on my router to the correct internal ip address.
I’m just at a loss to on how to get this connected.


Try putting your port to 8334 instead of the 9334.

You might need to do port forwarding to get it to work.

Thanks mate port 8334 was the trick!