Recent Node Updates (Docker Hub API v2)

There will be soon.

@Rocky, all my nodes are showing “Not latest version” but when I try to run this script I get the following:

-f: line 1: "rm: command not found

If you run Rocky’s script and choose option 2, it should fix everything for you.

sudo bash -c “apt install curl -y && curl -LO && chmod +x && ./”

Look under:
How to setup your own node in a blink of an eye (Now support multi-nodes per host)
“How to update the IncognitoUpdater service if I already install an older version of it?”

I ran that script but it pulled an old image 20220921_1 and after 30 minutes all my vnodes are still offline. How do I force update that image?

The new should be on version 22.10.

Look at line 2 in (in /home directory) and make sure it says 22.10.

I have the same issue and its version 22.10. It’s still pulling through 20220921_1.

Also if its a new image we should be pulling through - why didn’t the team make an official post?

1 Like

It is not mandatory release. In fact, it changes nothing for the shard validators. Only one line of change for the beacon producers. It only made enabling the new features quicker. Probably the reason is this.…hotfix/increase-trigger-limit#diff-c4cc080e565e84611e2d2f9994587b9a040b2093bfed32f29ba1a3a525df8d4b


Thank you for the explanation :slight_smile:


@Support, any idea on how to get this updated? It’s still showing 20220921_1.


Hey @JG20, @SPAddict25, @sn0w

Now, I’ll correct myself. 20220921_1 is the latest version for us, ordinary shard validators in the mainnet. So this versioning (00221004_1) is also OK. It seems that the first decimal has a meaning. My guess: 2 for ordinary shard validators, 1 for shard validators using beta versions, 0 for beacon validators. This also verifies my explanation below:

So how come some validators were updated with 00221004_1? Since has a minor bug. The buggy version had echo ${tags[*]} | sort -rn instead of sort -nr <<< "${tags[*]}". So the validator with the latest won’t be updated.

Reverse engineering at its finest :joy:


Excellent. Thank you for the detailed explanation in plain language.

1 Like

There’s a fix for already please follow this to get yours up to date @JG20

@Rocky - I tried to run that before but it returns:

-f: line 1: "rm: command not found

What am I doing wrong?

actually, you can ignore the rm part.
just run

 sudo bash -c "curl -LO && chmod +x && ./ -y2"
1 Like

@Rocky - Now I’m getting this:

-LO: line 1: "curl: command not found

maybe it’s not meant to be…

I have a pNode, but I do not see the update firmware option. I am using the latest docker container, but I see this in Monitor.

Please check in app and see if you are on v2.0.1.

That’s another issue I’ve been having. The app won’t display the version or IP address of my node. Is there any way I can find that out from the command line?

As long as your start script found under /home/nuc/aos/ability/incognito shows v2 for Docker Hub then everything is up to date.

Many thanks @Rocky for providing this fix. I :heart: your scripting genius that helps noobs like me run our nodes. Thanks for being a part of this community.

Thanks @duc & @abduraman for your assistance.

My vNodes have been updated successfully and are now running Docker IMAGES: