Provide Withdrawal Still Pending

Has anyone else been having this problem? Tried withdrawing a small amount and it has been pending since 02/14/2021 Thanks in advance

Yes, withdrawal from provide can take up to 72 hrs and it it seems there is some backlog at the moment. Also waiting patiently, you can see some more discussion here: Provide withdraw pool


Withdrawals have been slow but it’s due to many small withdraw request being qued. It takes a little longer than usual but it does process. I’ve heard the core team is looking for a solution to this by possibly putting a minimum on the withdrawal request.


36 hours for me and i tried 2 days ago!

It went through earlier today. Usually it doesn’t take long at all. Though, I understand that the network has been busy. Things will normally take longer.

My main concern was if there was an issue with an recent update or something glitching it out. I was wanting to consolidate all of my provision under one wallet, and I didn’t want to try that if it a glitch was occurring and end up losing all my funds.

Mine went through earlier today (wait time was a bit over 37 hours). Admin said in another thread that the withdrawals queue is clogged with small withdrawals.

1 Like

Im not seeing a pending transaction in my wallet from my withdrawal from provide. I’ve withdrawn from provide once before and i saw a pending transaction last time, so the discrepancy is a bit concerning to me. Please help

Welcome to the community @Wavetrader…send a ticket to @Support so that they can get back to you about the issue and @918273645 that lil - sign next to the amount you are expecting to have withdrawn is what reflects its pending status…these days there is a has been a backlog on withdrawals but it will complete… :sunglasses: