Official pNode Troubleshooting Guide

Thanks @Jared! I haven’t performed the advanced instructions, but I will do it tonight and report back here.

Would be handy to show how to access the “pNodes dashboard” as it wasn’t obvious when going through the steps.

(IP Address)

Answer: http://[Insert Your IP Address]:5000/

Example for the one above:

1 Like

Perhaps you missed this?

Or this.

It is not blatantly obvious from how it is currently written in my mind, so figured I would share incase any others are having the same issue.

1 Like

@Jared Step 1 shows up as the first 2 steps.

I am confused about how to access Docker. I don’t currently have Docker on my computer and am wondering how I set that all up/if I need to.


My pNode got slashed, the beacon is back to latest, how do I get the team to restake it?

Please send a message to the @Support account with the following:

QR Code:

1 Like

I sent a message to support

1 Like

@Jared There’s a spelling error in the command output above for the word ‘protocol’

Hello @sysfu,

Are you referring to @mpilot’s comment?

Correct. Also my node is down for two days, beacon stalled. Tried restarting docker, then restarting node, then deleting beacon, no success. Tried to pull logs to send to support but it downloads a zero byte error.log file. Tried deleting all data along with upgrading OS, still stalled beacon. HALP!

Do you have a chance to do a remote session? I can connect in now if you are available. Download TeamViewer ( and send me the generated User ID and passcode via PM.

Yes, give me five minutes and I will DM you the ID.

1 Like

@Jared A question and request.

Question: When I used the pnode dashboard at port 5000 and tap on system version red button at bottom, I get the following json output:

{“sensors”: [“product_control”, “stop_check_update”, “continue_check_update”, “check_internet_connection”, “start_check_internet_connection”],
“version”: “2.0.2”,
“type”: 0,
“is_service”: 1,
“boot”: true,
“application_file”: “”

Should this product control Version number here “2.0.2” correspond to firmware version number displayed in phone app or perhaps to some other number ?
[It should also be noted that my pnode firmware version number does NOT consistently display in the wallet app screen under the ip address of pnode.]

The above relates to my request below:

As a node operator and wallet user, I would like to know easily that I am running all the most recent versions which now involves separate version numbers like the TAG number of the docker container, the firmware version of the pnode, and the phone app version and perhaps the above product control version. It is kind of inconvenient to track all these down in separate threads on this forum. Is there a way somewhere in this forum to have a PINNED page or a CATEGORY where with one click I jump to a post that lists all the current/latest version numbers of each software component of the network that we all should be running in order to be up to date. It would nice to have a quick and easy place to check all of our different version numbers against what the devs are saying is the latest published versions of each. It wouldn’t have to be much, but easily found here in the forum and updated when needed.

Current Docker Tag:
Current Wallet Version:
Current Pnode Firmware Version:


@Socrates, This is a great idea! I will put together a short post soon with all up-to-date information for Validators and pin it permanently to the Validators category here on the forum.

Give me a little bit to compile all the information and get the links arranged. I will also personally update it as new versions of things are released.

1 Like

@Jared Thanks for the pinned current versions post. That will be helpful to us all.

You didn’t answer my question above about the “version” number I get in the json file when I tap on “system version” button in the pnode dashboard terminal window. What does this version number refer to? Pnode firmware version? Or something else?

Ah, sorry about that. I wasn’t ignoring you just waiting for a reply back from the devs.

1 Like

Hi @Socrates that is version of product control . ( the dashboard) .
For firmware version : you can check in app wallet.

1 Like

When I open my node’s dashboard on port 5000 my interface looks totally different… what am I doing wrong?
Screenshot 2021-10-18 at 10.37.54