Node screen is showing import button?

Why is this saying import help? I have the it connected to digital oceans serverimage

1 Like

You need to import the private key associated with the validator key you used on your vnode


Thanks @Thriftinkid for giving a quick help! :raised_hands:

@Bria77, pls make sure the keychain associated with your node is currently listed in your app. If it’s not, go to Keychain tab and import its private key.

By this action, you can easily monitor your Node operation and withdraw the rewards when your Node earns.

Important: do not forget to backup your private keys in a safe place. For the time being, private key is the only way for your account recovery!
How to backup private key >

1 Like

See it doesn’t list a keychain and when I try importing it says the keychain is already associated with this account

@Peter maybe you could jump in this case to help @Bria77 with setting it up?

Hi @Bria77, if you have the associated key chain available in the app already, let’s check the Node config on your server:
Is it running with the correct validator key? You can use this command to check:

Make sure you have attached it like the screenshot below.


If your validator key is not there, simply replace the current string in that row with your validator key, then press Ctrl + X => Y => Enter to save it.

Restart the Node by this command so the update can take effect:

sudo bash

1 Like

Hi, I have the same issue and followed the instruction and still have the import keychain step showing up for my vnode. Any other clue? I used the Anon ketchain.

Hi @klar, enter this command and let us know how it is showing:

sudo docker ps

Hi, so I worked more on it and the problem was that I was using my external ip address to access the vnode from the app. It worked when i used my internal ip address.

so as i understand it this is only required to set it up and do admin stuff on it? I dont need to have my vnode ports exposed to the internet right?


your vNode’s ports will automatically be made accessible from the outside by the docker image. It will even go around any rules you make using e.g. “ufw”

I don’t understand how you use the internal ip to access your vNode though. Where are you hosting the vNode?

I host it on a desktop machine inside my home network.

2 posts were merged into an existing topic: Import message randomly appears for vNode owner

If of any interest for someone, I use WSL 2 on windows 10 with the ubuntu image and docker with WSL 2 option activated.

It runs the official script ( without any modifications.

if you are running at home your node will behind a router and you would need to manually open the ports. it‘s not necessary to run the node and earn but would be beneficial for the sake of exchange of data on the network. it‘s currently done by highway nodes afaik run by the incognito team which is currently ok but not ideal for long term centralization imho

okay, got it. Its open. thanks

1 Like

And for the app to be able to find your node you need to add the port it is at.

For example

I think his problem is that he didn’t open 9334 on his router and added a rule to forward this port to his node. This way he can’t reach his node by <external_ip>:9334 but it does work internally with <internal_ip>:9334. At least that’s my understanding…

It seems that for a reason that I dont understand yet, i was not able to use my ext ip address to reach a local machine when i’m on my local network. When i switched to the mobile network, the ext address works. The forward rule in the router was always there. Anyways, it’s working now! Thanks!

1 Like