Multi-VNode script

What are the steps / things to install on a fresh VPS? I’m getting errors because this script doesn’t install docker or other required programs.

I tried but failed at pulling parts from the original node script. :confused:

2 Likes

Run the following before running the script: docker -v || bash -c "wget -qO- https://get.docker.com/ | sh"

2 Likes

I’ve updated the script to install docker and kill any other instances of incognito.sh on launch to prevent conflicts

6 Likes

@mesquka Can we just update the script with more validator keys to add more nodes or is there a more recommended way to add nodes? I already used your script to get a few nodes running but now I would like to spin up some more nodes.

I did this and both are running good just haven’t been paid for around 7 days is that normal?

Yep, if you add in new validator keys and then run the script again new instances should be started up and run.

1 Like

Yeah, if you can connect your nodes in the app or on my tool incognito.mesquka.com then they’re running fine. Earning slots are a bit random, see this topic for more details: My Node hasn't earned in x days/weeks

2 Likes

hey I did this but i do not see eth_mainnet running is that okay?

Yes, the script doesn’t start eth_mainnet. I’ll add this in as it seems like the nodes use it now. I had removed it as they didn’t seem to be using it previously.

1 Like

So do we need that? because my nodes are running without it?

When I run multi nodes I see this error that comes out in the log.txt not the error_log

The multi-vnode script doesn’t change anything inside the docket containers, so that’s not a consequence of this script

1 Like

One of my nodes that was setup using your script earned just a day or two ago. Any reason to rerun this script?

Have you seen that error in the logs prior?

I haven’t looked at my logs. I just check that the port is open and that it maintains uptime.

I’m trying this out on a vps with an existing node. I replaced key 1 with the existing node and key 2 with the new validator key.

  • I run it and after some errors around the initial node already binding the port.
  • I check docker ps. In docker I see inc_mainnet, eth_mainnet and inc_mainnet_1 which looks good to me, inc_1 is cranking away at ~100% CPU.
  • I added the node in the app and staked it.
  • When I added it to https://incognito.mesquka.com/nodes I don’t see an error but it is blank in the box. Should I expect it to say -2 if everything is good? Or how long will it take the tool to catch up?

If the node is showing up in the incognito tool, it’s up. Does it display a BLS key? If so it’s running fine.

One does now but one is still blank. For a test I added nonsense ip and port to see if the tool threw an error but it didn’t which is why I reached out.

I realize now that I had one with ‘direct connect’ and one without. Without is now showing -2. I’ve removed direct connect from the other, we’ll see if it shows up

If it displays in the node tab, then the node is running. When the BLS key shows then the node is ready to stake and will begin earning once the node is synced. I’ve got a backlog of things to work on, but am hoping to get back to the incognito tool and work on making error messages etc. better.

1 Like

Now I unclicked direct connection everything is showing -2 as expected. Thanks for creating the script!