Moved vnode from AWS to Contabo, but ports are not connecting

I moved vnode from AWS to Contabo, but ports are not connecting. I stopped the AWS and did curl to contabo and it seemed fine, but now i can’t connect the node. does it just take a while?

I tested the main ip with this website and it works with port 22, but with 9334 it’s not working.

docker stats and docker ps look good, but do i have to forward the ports now?

Not sure what to do. please help!

Hi @Joe_Moffett, did you open these ports: rpc port & p2p port?
This is a related topic: Advanced set up: customize the port of your Node

That is kind of weird. I run several servers with Contabo and have never fiddled with port settings. Are you sure you are using the right IP address?

I have no idea what’s going or what I did. I’m starting to lose it.

I started with AWS and everything was working up until recently, but I must have made a million mistakes.

And now I can’t access my AWS instance from terminal bc it won’t recognize my private key. I feel like i need to start from square one, but don’t even know how to do that

yea they gave me an ip address and a vnc ip, i used the regular ip not the vnc?

I tried using these instructions, unfortunately, i cannot figure it out. I tried the rpc thing, but nothing was working, but honestly i just don’t know what i’m doing

Did you use your validator key to start the node on Contabo?
It doesn’t work with your private key.

Joe if you used your private key I suggest to transfer your funds to a new account and delete which you exposed. I did not do any research on the topic, but your private key now potentially present in many log files.

Thanks @raz for the heads up will do ASAP I hope that’s not the case, but just in case I will start switching over

Wait are you saying if I used my private key in the curl function? I didn’t do that if that’s what you are saying

1 Like

Solved - I’m stupid! Thanks for the help everyone and sorry for that

Basically, I was just doing things out of order all over the place because the amazon set up was so different and had pictures, so I was clonflating instructions. Lessons learned!