line 57: jq: command not found

Ubuntu 22.04.2 LTS

Starting off with the above, installed docker engine, ran the interatcive script and received the following errors:
journalctl -t IncNodeUpdt

Feb 23 07:09:15 anton-MS-7C91 IncNodeUpdt[307204]: Getting Incognito docker tags
Feb 23 07:09:15 anton-MS-7C91 IncNodeUpdt[307269]: /home/incognito/ line 57: jq: command not found
Feb 23 07:09:15 anton-MS-7C91 IncNodeUpdt[307204]: Current tag || - Latest tag ||
Feb 23 07:09:15 anton-MS-7C91 IncNodeUpdt[307204]: Cannot get tags from docker hub for now. Skip this round!

Is this an issue that has been mentioned here earlier where Ubuntu 22.04 does not work well with Docker? Or is there are fix for this?

I also installed jq from this source and still nothing.

What script did you use to set up this node?

sudo bash -c "apt install curl -y && curl -LO && chmod +x && ./"

from here: How to setup your own node in a blink of an eye (Now support multi-nodes per host)

What does sudo docker ps show?

4ea29a7ae14e   incognitochain/incognito-mainnet:20230209_1   "/bin/bash run_incog…"   2 hours ago   Up 2 hours>8334/tcp, :::8334->8334/tcp,>9433/tcp, :::9433->9433/tcp   inc_mainnet_0

Your node appears to be operating correctly, you can safely disregard those warnings in the log.

What does Node Monitor show? If your node is Latest then there is nothing to worry about.

Let me check if I can get the node going. Havent even tried yet as I was trying to get the error messages solved.

IIRC the app needs to be on the same IP as the node when I set it up is that correct?

This is for a vNode, correct? You do not need to be on the same IP subnet as long as you know the IP address for the node. I would recommend using dynamic DNS like DuckDNS so in the event your IP changes you don’t have to remove and readd to the app.

Hosting it at home on a server. Does it make that a Pnode? I happened to have two ISP’s where the app is on one and the node on another. When I go to “Power”
on the app, enter the node’s IP address’ and then click “add”, I ge the following screen instead of the option to stake.

The app relies on communicating with your node’s RPC port. It could be that you need to allow access to this port on your modem/router.

Some users have reported they don’t need to do this, however, I’ve had to open the ports to get mine to work.

Side note: I see you’re using a VPN. Try turning that off and refreshing that screen.

thanks will do and report back.

1 Like

Oh yeath the VPN. Will try that first.

1 Like