Issue with Staking a new vNode & Sluggish Performance

Bug # 1: It looks like something is wrong at the back end, as I am having issues staking a vnode. I’ve tried doing this intermittently a few times in the past 5-6 hours, but the issue still persists. See screenshot below.

image

Calling upon a few core team members to look into the issue, as I am not sure if this is an isolated issue or a systemic problem that must be fixed.

Bug # 2: Also, the “Power” or nodes section of the app is experiencing a sluggish performance in terms of speed for loading the page. I’ve observed that the performance degrades with each additional node you add, and it takes a long time (>5 minutes) once you start tracking a total of 10+ nodes. @Mike_Despo - have you experienced this issue too? Any one else in the community seeking this as well (especially if you’re hosting multiple pnodes or vnodes)?

5 Likes

@sid Staking and unstaking is paused at the moment. Staking & Unstaking paused I guess this is the reason why you having problems right now.

6 Likes

As sato mentioned, there is a post with information on the situation. Please don’t tag everyone, we are all here, and read just about everything posted.

7 Likes

Yes, I have this issue. Loading time for my node screen is very long. Luckily, I don’t need to go into it very often, except maybe once a week to withdraw earnings.

5 Likes

Same here, not a pressing issue but something that would need some attention at some point in time! Thanks for confirming! :slight_smile:

4 Likes

Sorry, should have used a few more specific keywords to search here. I’ll take the feedback on tagging. :+1:

5 Likes

Hi @sid, we paused the Staking/ Unstaking process as sato mentioned above.
Our fullnode will reject those related TXs, so your transaction will not go through.

About the Bug #2: We are aware and there will be an improvement soon next month.

5 Likes

Sounds good, thank you for all the great work you guys are putting up for this project! :slight_smile:

5 Likes

Hi @Peter,

I noticed you posted an update yesterday that staking/unstaking has resumed and the bug has been resolved on this thread. However, when I tried to unstake one of my vnodes, I still see this error:
image

I checked and I don’t have any previous or outstanding transactions. All previous transactions are marked as complete.

Any insight on how do I go about resolving this issue?

3 Likes

@sid is that message appeared for the first time you tap “Unstake”?
Let’s try to restart the app, and provide a screenshot of that Node 246.214 in the Node screen. I want to see its status.

1 Like

Hi Peter, I figured this out. It looks like there was an issue with the way this vnode was staked originally. I staked this vnode on a few minutes before the scheduled downtime for pausing of staking/unstaking. Meaning that the node never got staked, but it appeared as it was successfully staked. I found out that the 1750 PRV staking transaction had failed, and the tokens were back in the base account.

I removed the vnode, and added it back and attempted to stake it - and it went through smoothly.

3 Likes

@sid I see. That’s why it shows the balance is 1,750.01 PRV at that time. Thanks for your confirmation.

2 Likes