Is the beta fullnode down?

I’m getting this error while trying to use an RPC:
{"Jsonrpc":"1.0","Method":"getactiveshards","Params":[],"Id":1} error: Post "": dial tcp connect: connection refused.

1 Like

What other fullnode can I use in the meantime, @Support?

Right, I was just about to ask this as well. I use it in my scripts to check reward balance.

1 Like

Hey @Support, what’s the status on this? I find it a bit problematic because even if I use the --host flag, it tries to contact for getactiveshards, why is that?

1 Like

Exactly. I have tried that too. Incognito cli is not working at all now

@fredlee, maybe you could try changing the source code and build it by yourself

Hey guys, there was an issue with the community fullnode that is hosted on OVH. We are checking to get it back up asap. Regarding the configuration CLI tool for pointing to other fullnodes. @khanhj is looking into and providing a quick solution soon.

to modify the mainnet fullnode url in incognito-cli

go to:

/home/$USER/go/pkg/mod/[email protected]/incclient
sudo nano constants.go

and modify MainNetFullNode address.

then rebuild incognito-cli binary:

However, the fullnode doesn’t support submitting key for indexing coins, so it would be better if you can use your own fullnode with same method in my post above.

I don’t get it, why are these not used?

   --host network                              Custom full-node host. This flag is combined with the network flag to initialize the environment in which the custom host points to.
   --network value, --net value                Network environment (mainnet, testnet, testnet1, local) (default: "mainnet")

(Well, to be fair, network is used, but even if I do --net local, it uses the host from constants.go and not --host)

1 Like

yeah we will fix the bug about input params --host later. But i can say modify constant.go in dependency repo of go mod would work.

1 Like

Nice! Yeah, I modified contants.go according to your instructions. I put my own server info under local and use --net local works like a charm. Thank you for your quick reply!

1 Like

I’m getting an error when compiling it imports imports imports imports imports cannot find module providing package

Pls try command go install first.

Hey guys,
this fullnode is back online