How to host a Virtual Node

Thank you again. If I unstake the incorrect 2nd node to remove it, will it unstake the first node?

I changed the validator key for the 2nd node. The app detected the change and recognized that it was for the new Keychain. However, it is still not staked. The app won’t let me unstake this 2nd node because there is no PRV in it to pay the network fee. :cry:

I am not sure I am getting this correct… You have two keychains both hold at least 1750 PRV. Keychain 1 staked 1750 to Node 1 and Keychain 2 is supposed to stake another 1750 to Node 2. Correct? I don’t think you can stake the same node twice so you don’t need to unstake Node 1.

Please correct me if I am wrong…

1 Like

Oh. I didn’t move the 1750 PRV to the new Keychain 2. I’ll do that and see what happens. Thank you.

You should be able to stake the 2nd node from the other keychain! Let me know if it worked…

I now have 1751 PRV in the new keychain. The 2nd node was already added previously. I don’t see any way to stake it at this point. I tried just adding it again, but I think the app doesn’t let me since the IP address is already added to the unstaked 2nd node.

You seem to be mixing things.

  • You have node 1, staked and running.
  • You installed node 2, but used the same keychain. Everything you see on this node 2, is related to node 1. Don’t touch anything.
  • You have installed node 2, with a different keychain. Not sure how you added it, but it might be wise to remove the first version of the node 2 from the node tab, and add node 2 fresh
  • The stake button should show up
  • With the 1751 PRV in the keychain that is assigned to node 2 you should be able to stake node 2

Hi. Thank you. Is there a way to remove node 2 besides installing it? I tapped the unstake button. Do I need to wait for a couple weeks? The unstake button has not changed since I tapped it. If I tap it again it says to wait for the previous transaction to finish.

You most likely unstaked node1

You can remove a node from the Power tab by swiping to the left. This will not do anything to the stake that is already present on the node.

The important thing is to have the private key of every keychain you use stored safely, offline preferably.


Thank you! I was able to add and stake node 2 after removing it first. Node 1 still seems to be ok but I’ll just keep an eye on it.


Hi @Peter, is there an official script that to Uninstall and Remove Incognito and Docker from my Ubuntu PC?

Reason being, I un-staked and move the funds to the new HD wallet. I took the opportunity to setup a new vNode and staked from my new wallet to a new PC. Hence, I want to free up space on my old Ubuntu PC. Can you assist me please?


1 Like

Hi @Linnovations
To uninstall the Docker, please follow Mike’s instruction above.
To remove the database of the Node, let’s try this:

rm -rfv data

ps -ef | grep

kill -9 <process id>

docker stop $(docker ps -aq)

docker system prune -a

Thanks @Peter and @Mike_Wagner for these instructions. I was able to successfully recover significant drive space on this PC :slight_smile:


Hi guys,

It’s been a while, i have updated the first post.
What’s news:

  • adding step to register infura account
  • add infura api key to script
  • remove geth/parity in script

In PRV we trust!


Hey @Roman, I’ve just DMed you for an investigation, and it would be better not to get the topic confused.

1 Like address returns nothing although it works in the browser. I think docker site has added a redirection but curl cannot handle this. registry should be removed. So the correct address is FYI. @Support


Should probably add -L or --location to curl command to avoid this next time.

1 Like

Hi All,

I’m having difficulties getting my virtual node set up? Is there a forum where I can get some support? Anyone willing to help me?

I’m a noob, so please take it easy on me :slightly_smiling_face:

Hello @palant1r,

This forum works. You can message @Support directly or ask the community for support via our Telegram channel: