Hosting a Virtual Node from Home

Hi @Chucky, this is very helpful information.

My aim is to run a test vnode on my home PC (which is a Chromebook running Linux). I have ordered a Mini PC called a Chuwi LarkBox which I intend to be a more permanent vNode, hence this Chromebook is my testing ground.

I wanted to see how difficult it would be for me to run a virtual node myself. I have run into a few glitches along the way (it hasn’t been all smooth sailing) but the community and yourself have been most helpful in addressing my questions.

I want to buy one of the new Node Trees once they becomes available, but my LarkBox will be an interim vNode solution. I really feel passionately about this project as privacy is essential for digital money to succeed.

I think I have sorted out my issues on my Chromebook and my Vnode is back up and running. I have been able to sort out opening ports on my router and Chromebook (something I’ve never done before).

I’m going to seem how things go with this Vnode and hope to earn some PRV from it soon.

Thanks again for all your help.

3 Likes

Yes i remember you mentioning that tiny tiny pc and that you were going to try and run a node on that as a nice experiment.
Glad to hear you home vnode issues are getting sorted, software isnt always smooth sailing. Eager to see the results of the experiment :slight_smile:

3 Likes

Hello Incognito Team,

I’m having some strange issues with my Virtual Node. When adding the vNode to my wallet I see the following (screen shot attached)
SmartSelect_20200819-203436_Incognito Wallet

I have run through the steps outlined in the “FIX” button.
I can confirm that my Port 9334 is open on this Linux machine with IP 58.164.38.229 , and that Docker has these 3 “container names” running:

  1. inc_logshipper
  2. inc_miner
  3. inc_kovan

I have removed this Vnode and added it back a dozen times over the span of the last week and I get the same result.

Can someone please help me with this issue?
Perhaps @Chucky, you may have some ideas?

1 Like

When I check your Node’s connection I get an error. Where did you check open ports?
image

2 Likes

Thanks for looking into this @Jamie

Here’s what I see - Screenshot_20200819-232637_Vivaldi

Also , this next screen shot just taken now after removing then re-adding the Vnode at IP address 58.164.38.229
Screenshot_20200819-232902_Incognito Wallet

I have also check my Linux terminal via
$ sudo docker ps
I see that 3 containers running as outlined in my previous post.

Is there anything I’ve forgotten to check?

Is the server NAT’ed? Do your have your router set to forward requests to the ports on the server from the external IP?

2 Likes

Hi @fitz_fiat, Thanks for the reply.
I’ve configured my Home Modem-Router (that has an inbuilt firewall) with the following Port Forwarding configuration, where 192.168.0.14 is my PC running Linux and Docker container for my vNode.

Here’s a photo of my firewall port fwd configuration -

Please confirm this is OK?

Hey @Jamie, do I need to forward any other ports?

I am not too familiar with running vNodes at home locations, just with VPS installs. At this point adding more ports will not solve things. The 9334 one needs to be accessible to begin with. Which doesn’t seem to be the case.

Hi @Jamie, I took this photo just now…


Under the canyouseeme.org ‘success’ message is my Docker containers running.

Any other troubleshooting ideas from anyone?

I really want to get my vNode working on my home PC and not have to rely or pay for a hosting provider.

1 Like

Can you use this post instead of the other one? It will keep information more organized. And will make it easier to find for people who can help, or want to do the same thing you are trying to do.

Also, if you can, adjust the size of your images so they show up in whole instead of partially.

If the port is open, then maybe the ip of the node changed. Did you set a permanent address for the node to use?

2 Likes

Hi @Jamie, thanks for splitting this thread out.
Yes, my PC is running Docker and incognito containers has it’s IP address fixed on my home network to 192.168.0.14

Add port 9433
If that doesn’t solve it then add 8545 and 30303 for both tcp and udp.

Also make sure your ‘docker network inspect <inc_xxxx> ‘ is setup and reports your processes.

You may need to verify that you don’t have any firewall rules in place on your server as well. Some have it set to not allow inbound communication and certain outbound.

Make sure you are running docker with the sudo command and not just as a user.

That’s all I can think of that might be blocking you.

1 Like

Hey @fitz_fiat, I am a newbie to Linux but keen to learn so I feel like I am in deep with attempting to run my own Incognito virtual node.

You mentioned about checking my server’s firewall. That may be my problem as I didn’t know how to check this in my Linux installation.

Can you share any commands I should run to check these settings? Thx.

Unfortunately it depends on the flavor of Linux, districts and version.

For Ubuntu

sudo ufw status

Will show you what is going on.

Also look at the configuration info for running your own vnode on the incog site.
You should see some examples of different firewall setting to use.

Best alternative since you are behind a nat’ed router with a firewall is to turn your servers firewall off all together.

Make a note of the website and commands that were used and save in a file in your vnode directory so that you can reset later.

Best wishe

1 Like

@Linnovations :wave:t6:
It's really cool that you're working on this! I have a vnode at home just like you. When adding your home vnode, you must specify 192.168.0.14 instead of the external IP address. when adding it, you must be in your wifi network! Good luck!
P.S. Let me remind you that your computer must work 24/7

If you have multiple vNode on the same computer, use the ports to add them…example: 192.168.0.14:9334
192.168.0.14:9335 192.168.0.14:9336 …

20200820_115258

3 Likes

An issue became known (and solved) recently, the run.sh file was pointing to testnet instead of mainnet. Seeing you have an inc_kovan container running means you are working on testnet at the moment.

Take a look at this post

1 Like

Thanks @Jamie for bringing this to my attention. I re-deployed and no more inc_kovan.

What I see now in docker is :-

  1. inc_mainnet
  2. eth_mainnet

However, I’ve run into another issue on my Linux box. My Terminal keeps crashing after running my Incognito vNode for about 15-20 mins. This forces me to close and restart my Linux Terminal.

Below are the pair of error messages I keep getting (remember I’m a newbie to Linux so this is jiberish to me)

[ERROR:utils.cc(50)] Failed to read message size from socket: Connection reset by peer (104)

[ERROR:vsh_client.cc(232)] Failed to read message size from socket: Connection reset by peer (104)

Can someone help decipher what is going on with my Linux Terminal and is there a way to prevent these errors as it is impacting my vNode uptime?

For those following this thread, I mentioned earlier that I would attempt to build an Incognito vNode on the world’s smallest mini PC the CHUWI LarkBox - https://www.indiegogo.com/projects/chuwi-larkbox-world-s-smallest-4k-mini-pc

Screenshot_20200926-170552

I have just recieved delivery of my LarkBox.

If there is enough interest, I will work on documenting every step I take from unboxing, through to Linux OS installation and installing Incognito Virtual Node.

Does the community see value in me doing such a post?

2 Likes

Absolutely. It would be better to start a new post on this subject and probably leave a link here and in a comment of the post about getting a Raspberry Pi to run as a node. That will make people who are interested in doing something similar aware. They can help or copy, who knows.

1 Like

Ok, thanks for your feedback @Jamie.
I will endeavour to start a new post.

Question: Does it matter what flavour of Linux I run my vNode on?

I was thinking of running Ubuntu as I’m a complete newbie when it comes to Linux. I’ve been Windows and Mac user my entire life but never used Linux before.

Is Ubuntu my best choice of Linux OS?