Can't unshield / send coins..


I can’t unshield or send some coins - I believe it’s all the coins that have a lot of history… At least that’s my guess as to why / which coins won’t work. I use incognito a lot - and have a TON of transactions (my guess is 10,000-20,000 trades[swaps], but I could be way off)

If I tap on Wallet, then pick one of the coins I’m having trouble with (for ex. PRV), I see the screen with my coin (PRV) balance, the current price, the Buy & Sell buttons at the botton, and the circle drawing continuously… I have left if for quite some time, and nothing happens. I don’t see any of the transactions, it just spins. There is no response when I tap on the three dots (…) - to try to send.

Everything works fine with coins that don’t have many transactions, but that’s all - it just hangs for coins with a lot of transaction history. CSV Export does not work either - which again, I’m guessing has to do with my extensive history.

I was going to move all my coins to a different incognito account because I thought there was an issue with the history, but I guess I didn’t do it soon enough, because now I can’t! I honestly don’t care about the history, if that’s easiest for you to erase or truncate it.

This is a new Google Pixel 6a - it’s not an old phone. I have cleared the cache, local history, and even cleared all app data recently (and restored by seed phrase) due to another problem I was having.

Please help!

Helps on the way. I’ve pinged the devs :slight_smile:

1 Like

Thank you!

hello @yoo

According to your info, i suggest you using incognito cli to double check balance and consolidate your coins.

I assume you have windows laptop, I will show you commands to do, if everything went fine, you can still using current account, otherwise, I’m afraid you have to move fund to another account.

Download the incognito-cli pre-compile binary here

after download, unzip the file, open windows powershell
go to downloaded location, try this command:

.\incognito-cli.exe -c 1 -d 1 account balanceall -p YOUR_PRIVATE_KEY 

it should look like this pic:

It took just over 5 minutes, but that worked. I don’t know what all the output is, but the last section appears to be 41 coin ids & balances?

Great, i believe it looking like this:

"0000000000000000000000000000000000000000000000000000000000000004": 28845928368,
"0dfc519d73c1664858ac27111258e0e287f0f6fa900a1ff9d4bb4ad1443092f5": 2640197417,
"1ff2da446abfebea3ba30385e2ca99b0f0bbeda5c6371f4c23c939672b429a42": 2894467,
"2a6ba49aed10ec37c042d0c0dd26ad83575c5e7ae93c7327766f532e03d8f2ac": 8988089,

So in this example i have: 28.845928368 PRV

Please prepare another incognito account to transfer your fund.
Here is the full incognito-cli command list

Let’s focus on command send, try to send 1 PRV to your new account to make sure it worked:

.\incognito-cli.exe -c 1 -d 1 send --privateKey PRIVATE_KEY --address ADDRESS_OF_YOUR_NEW_ACCOUNT --amount 1000000000 --tokenID 0000000000000000000000000000000000000000000000000000000000000004


  • 0000000000000000000000000000000000000000000000000000000000000004 is token ID of PRV
  • 1000000000 is equal to 1 PRV

After sending completed, go to your wallet app, new account, and check balance to see if it received 1 PRV.

Then process the same by sending all other tokens to your new account.
The last one will be PRV, because you need PRV in your old-account for transaction fee.


Thanks, it worked & I have started moving coins over…